Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

After downgrading RC firmware, FPGA error with red light beep

Discussion in 'Inspire 1 Help' started by JJW, May 15, 2016.

  1. JJW


    Jun 25, 2015
    Likes Received:
    I downgraded AC firmware to and RC firmware to 1.5.8
    because after the latest firmware update(, "No signal" happened so often during flight so that I couldn't finish a job in front of many clients.

    After came back home, I tried downgrading the firmware of AC/RC but when downgrading RC firmware in DJI GO app, after 99% of progress and the last long beep sound, it displayed "upgrade failed" (which means actually downgrade to 1.5.8) (My tablet is Nexus 7 2nd with Android ver.6.0.1)

    So, I tried a mannual update method with a USB memory stick. But nothing happened when plugged USB stick. And when I rebooted the RC, there was no booting melody with white light in the first LED on.
    I tried downgrading again in DJI GO app, but the same happened (at 99% with finishing beep sound and "upgrade failed" displayed)
    And from that time on, whenever I boot RC, the red light flickers in the first LED with strong emergency beep sound.

    When I get into downgrade screen of DJI GO, it goes like this:
    -- Firmware version: null
    -- No available firmware to downgrade

    When I click overall status, it goes like this:
    -- Remote controller FPGA error
    -- Hardware malfunction. Contact customer service for repairs.

    I guess this must be a firmware corruption. How can I fix this?
    I can't send my RC for repair because I have jobs scheduled next week. How can I initialize the RC firmware?

    Screenshot_20160515-161034.png Screenshot_20160515-161416.png
  2. Karl Alexander

    May 22, 2016
    Likes Received:
    exact same thing just happened to me... any fix for this?