Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Can't get I2 to stay or relinked with Cendence w/ an attached Crystal Sky

Joined
Sep 22, 2018
Messages
1
Reaction score
0
Age
30
I have had a very difficult time getting an I2 to link with a Cendence w/ an attached Crystal Sky.

I have been able to establish a connection with the I2 only three times, for no more than 15 minuets, during which I have be able to operate the X5S, etc.

The I2 persistently displays LIME (Very clearly yellow-green light, not the connected green that I have seen three times) from the link button. The lime invariably blinks or is solid, including when pressed, held, etc.

On occasion, after reinstalling firmware, the light may be solid red, blink red, or alternate red and gree until the lime quickly returns. No link is established when this occurs.

When the Cendence and the Crystal Sky are on, and in the DJI Go 4.0 menu prior to entering the device, RC Connected is ALWAYS displayed.

That's about where I'm at, I have exhausted all troubleshooting options, including rolling back and re-updating the I2 firmware via DJI Assistant 2.0 twice, as doing the same for the DJI Go 4.0 app. I should also note that I have swapped out the Patch Antenna for the Omnidirectional Antennas and have seen no change, and that the I2 Contoller also will not connect, with either the Crystal Sky, an iPad, or a S8+.

Any help would be appreciated, DJI phone support only offered to swap out the entire kit along as it was within 15 days of yesterday.
 

Attachments

  • 20180922_124228.jpg
    20180922_124228.jpg
    1.3 MB · Views: 13
  • 20180922_124058.jpg
    20180922_124058.jpg
    917.9 KB · Views: 13

Members online

No members online now.

Forum statistics

Threads
22,332
Messages
210,835
Members
34,903
Latest member
Dfani511