Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Controller won't connect to dji go

Discussion in 'Inspire 1 Help' started by low_budget, Feb 13, 2016.

  1. low_budget

    Feb 3, 2016
    Likes Received:
    I bought a second inspire remote and the plan was to be able to use it with my Phantom 3 professional and as a second remote for the Inspire 1.

    I USB updated the new Inspire remote to v1.3.00, then I app-updated to 1.5.7.
    I never had any problem connecting to the Inspire, but when I tried pairing to the Phantom things got weird.

    The remote connected to the Phantom OK, but there was no live video feed, only black screen. I tried many things to try to fix this like resetting, re-installing dji go on IOS and Android devices and nothing worked on my v1.3.20+ firmware Phantom.

    In this process, I set the remote to slave setting. It disconnected. I rebooted the controller and it will not connect to dji go at all. On power up, the led turns red, beeps twice, then turns purple and does nothing. Now I think I may have bricked my controller.

    I was hoping there was a way to reset the controller to master without connecting to dji go. If not, I guess I'll be sending it back.
  2. Kurt S

    Aug 6, 2016
    Likes Received:
    Did you ever figure this out as I am having the same problem.