Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Disappointed with DJI inspire please help thanks

Aug 22, 2016
Reaction score
So have had the DJI inspire pro x5 for about 2 months. I have never been able to fly more than 100 meters away without losing video signal. Even at hole the video starts cutting out and bottom of iPad turning green. Flying on a wide open golf course with nothing around. Under the HD menu If I switch my inspire from auto to custom and chose a single channel like 19 for instance and drop quality all the way down to 4mb I might can get 325 meters with no video dropout or glitches till that point. Why does auto create more issues than custom channel? We are having to chase it down the golf course in a golf cart as to not lose signal halfway to the hole. We have all firmware updated to the latest firmware but hasn't worked with any of the updates to this point. Brand new batteries, 3 different SD cards, have tried using iPhone 6 Plus, iPad mini 3, and other iPad versions as well. We have tried in different areas as well. Every hole is the same. Middle of nowhere in North Carolina. It's pointless if we have to constantly chase it in a golf cart and not worth the money. Any help please? Never had this many issues with our phantom 3. Thanks.
Joe I've had an I 1 Pro for over a year & had no serious problem with the RC or telemetry/video links. But I have learnt the following;
1. make sure yr controller, i.e. IPad, Tablet Etc is man enough for the job. I have recently upgraded to to iPad Pro with cellular (no data service needed) and now get no dropped data, more accurate positioning & it doesn't get hot or crashed apps. Close all unused Apps on yr device before u start. If yr using autopilot or any other 3rd party app, make sure only ONE app is running.
2. Make sure there is no interference. Transformers, power lines Etc. As a test, switch all cell phones to airplane mode.
3. And the obvious, make sure yr RC antenna are connected firmly and the antenna pointed up
Last edited:
It sounds like you have something loose in the remote like an antenna wire
Also check behind front cover on bird make sure all your antenna's are tight 4 of them
Joe, I'm having the same issue with my Inspire 1 V2.0. I used it today and had to land it and finish the job with my Yuneec Typhoon H. I had the same problem with my DJI Phantom 2 Vision Plus twice. First time they fixed it under Warranty and then less than 3 months with hardly any flights it happened again and got charged for the repairs. Now I'm going to have to jerk around and send the Inspire 1 back to DJI for the same issues as I had with the Phantom before it's off warranty. None of these problems with the Typhoon H!!!
I have been having the same issues with my Inspire 1 Pro since updating firmware two versions ago. Very frustrating for all the money we spend on these.
What you don't like being DJI test rat that's all they do is pass new s*** out and let everybody else test it and then when something happens it's our fault

Members online

No members online now.

Forum statistics

Latest member