Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Firmware Suitable (Of Inspire 1 Aircraft, Remote Controller, Version of DJI GO App)?

Joined
Oct 22, 2019
Messages
1
Reaction score
0
Age
41
Hi Everyone, Please help to post on this room about suit of firmware that your drone system is working.
By the time, DJI Software team has develop and update so many version of firmware. Now, we need a suitable firmware that your drone system works well. Please, support or sharing info. about firmware of your drone system on this room for anyone who get the same problem with their system. At least, it can help them figure out or make sure the firmware that they did on their system is right.

Thank you so much to support my idea!
 

Attachments

Joined
Jun 28, 2016
Messages
958
Reaction score
371
Age
56
This subject has been covered many times in this forum. But as a favor, I will publish for you a working combination that won't let you down.


Go App: v3.1.1
Aircraft: v1.8.1.00
Remote: v1.6
X3 Camera: v1.8.1
X5 Camera: v1.11.1.50 (Lots of wiggle room on the X5 Firmware)

And, yes, DJI asks me to update my firmware every time I fire up the bird.

D
 
Joined
Nov 11, 2018
Messages
31
Reaction score
10
Donnie,

Thanks for this useful post! Do you happen to know if these same firmware sets work with the Z3 Camera?

Thanks
 
Joined
Jun 28, 2016
Messages
958
Reaction score
371
Age
56
Donnie,

Thanks for this useful post! Do you happen to know if these same firmware sets work with the Z3 Camera?

Thanks
I do not. I almost purchased a Z3 camera, but it was shaky @ zoom. The owner said it was perfectly smooth on his bird, so maybe the older firmware doesn't quite work with the Z3. I wasn't interested enough in the camera to pursue a solution.

D
 
Joined
Aug 11, 2019
Messages
18
Reaction score
0
Age
38
This subject has been covered many times in this forum. But as a favor, I will publish for you a working combination that won't let you down.


Go App: v3.1.1
Aircraft: v1.8.1.00
Remote: v1.6
X3 Camera: v1.8.1
X5 Camera: v1.11.1.50 (Lots of wiggle room on the X5 Firmware)

And, yes, DJI asks me to update my firmware every time I fire up the bird.

D

I have now hard time to get any firmware to my drone. I tried to roll back from newest to 1.08 but i suspect something went wrong since i still had the video problems (most of the times i fly i dont get image). I tried to do the firmware update again and based on your youtube videos and all seemed to go like you described. Drone was updating motors etc. But it just kept beeping almost 2 hrs and gimbal was very hot. How long should i allow drone for update?

Now i am in a situation where it is impossible to connect any RC to ac. I have one rc with 1.6 and one with 1.7.8 Have tried all combinations with phone, ipad and android tablet and cannot connect with any of those. If i put my x5 to osmo handle everything works well. I don't have x3 to do the update with that.


========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: WM610_FC550_FW_V01.08.01.00.bin
Upgrading ...

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: WM610_FC550_FW_V01.08.01.00.bin
Upgrading ...

========== 2014.01.01 00:00:10 remo-con disconnect======
Packet: WM610_FC550_FW_V01.11.01.50.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.
 
Joined
Aug 11, 2019
Messages
18
Reaction score
0
Age
38
update on the situation, tried to update to latest firmware with my z3.

========== 2019.10.27 09:46:34 remo-con disconnect======
Packet: WM610_FC350Z_FW_V01.11.01.50.bin
Upgrading ...
Result: Success.

But still cannot connect RC to ac (with latest firmware on rc).
 
Joined
Jun 28, 2016
Messages
958
Reaction score
371
Age
56
update on the situation, tried to update to latest firmware with my z3.

========== 2019.10.27 09:46:34 remo-con disconnect======
Packet: WM610_FC350Z_FW_V01.11.01.50.bin
Upgrading ...
Result: Success.

But still cannot connect RC to ac (with latest firmware on rc).
You have to roll BOTH RC's back to v1.6. As you have experienced, they will NOT connect with FW v1.7 or later.

EDIT: Wait...are you rolling back to v1.08 or not? I see v1.11 in the above nomenclature.

I have had dismal success rolling back firmware with the X5. You need to roll back the AC with the X3 camera. If you don't have one, borrow one.

D
 
Joined
Aug 11, 2019
Messages
18
Reaction score
0
Age
38
You have to roll BOTH RC's back to v1.6. As you have experienced, they will NOT connect with FW v1.7 or later.

EDIT: Wait...are you rolling back to v1.08 or not? I see v1.11 in the above nomenclature.

I have had dismal success rolling back firmware with the X5. You need to roll back the AC with the X3 camera. If you don't have one, borrow one.

D
I dont think its about the rc. I have different firmware on them since I have no idea what fw bird has now. I have tried to roll back to 1.08 without success (maybe due the X5 camera, dont have X3) and also tried to install newest firmware back there so i would have somekind of working bird - no success. So probably this one is finished and needs to visit DJI repair?
 
Joined
Jun 28, 2016
Messages
958
Reaction score
371
Age
56
I dont think its about the rc. I have different firmware on them since I have no idea what fw bird has now.
The log file will tell you which firmware you have. I assume everything else works. In other words, there are no OTHER problems. We're simply rolling back firmware to achieve better video feed. The work flow kind of goes like this:

1) Turn everything on and make sure it all works.
2) Roll back Inspire 1 firmware.
3) Check log files on MicroSD card to confirm roll back worked.
4) Your remote will no longer connect to your Inspire 1.
5) Roll back the firmware on your RC.
6) Bind your RC to your Inspire.



I have tried to roll back to 1.08 without success (maybe due the X5 camera, dont have X3)
Try rolling back one firmware at a time. It is worth noting that I rolled back from version 1.10.xx (as denoted in the videos I shared). I have not tried to roll back from v1.11.xx. I can only assume that rolling back from v1.11.xx is possible. That said...

You're in uncharted territory here. Not only did I NOT use the X5 camera to do my roll back, I rolled back from v1.10.xx. So you're going to have to do some digging and tireless experimenting to figure it out. I spent HOURS experimenting with different files before making those videos. You'll have to do the same.




and also tried to install newest firmware back there so i would have somekind of working bird - no success.
The latest firmware is the Devil incarnate. I would NOT do this.

So probably this one is finished and needs to visit DJI repair?
I don't know. Did it ever work in the first place? If so, a repair is not necessary. I would borrow or purchase an X3 camera. They're getting cheaper and I honestly wouldn't have an Inspire 1 without one.

Good luck.

D
 
Joined
Aug 11, 2019
Messages
18
Reaction score
0
Age
38
Okey now i got progress. I tried to put firmware 1.09 there and all worked.

========== 2014.01.01 00:00:12 remo-con disconnect======
Packet: WM610_FC550_FW_V01.09.01.30.bin
Upgrading ...
Result: Success.

But now here is where it gets weird. RC with 1.6 connected but the led was flashing red/green so I tried with my 2nd RC that had 1.78 and all worked well. My ipad has go app version 3.10.1 (Because i inserted wrong code when i did with the video instructions and downloaded this instead of 3.1.1) and it doesn't recognize aircrafts FW, pic attached. I then connected Slave RC with my phone in it that has newest version of go app and it says that the version is 1.11.50.

So log says 1.09 and actual FW is 1.11.50 . Everything seems to be working though.

is osmo x3 same device as x3 sold with inspire? Those are available for very decent price and i could use it for updating.
 

Attachments

Last edited:
Joined
Aug 11, 2019
Messages
18
Reaction score
0
Age
38
I still had the no transmission signal there, so tried again to have 1.08 there. Seems like i ihave 15 00 line the no detected part. But is it faulty x5 unit? Since the unit works well with Osmo.

[02070189]Firmware upgrading[4]...
[02072450][19 00] Firmware upgrade start...
[02084115][19 00] Firmware upgrade finish failed (step = 4, err = 0xaa, idx = 0, los = 1, ng = 0, usb = 1).
[02094163]Done.

[02094211]Version checking[5]...
[02094265][01 00][05] v1.22.5037 -> v1.22.5037 need upgrade
[02094321][01 01][05] v1.22.5037 -> v1.22.5037 need upgrade
[02094379][01 04][05] v0.2.4270 -> v0.2.4270 need upgrade
[02094464][03 05][05] v34.1.0.5 -> v34.1.0.5 need upgrade.
[02094544][03 06][05] v2.4.10.7 -> v2.4.10.7 need upgrade.
[02094602][04 00][05] v1.29.0.92 -> v1.29.0.92 need upgrade.
[02094704][05 00][05] v3.0.6.2 -> v3.0.6.2 need upgrade.
[02094773][08 00][05] v2.14.9.26 -> v2.14.9.26 need upgrade.
[02094833][09 00][05] v3.0.0.4 -> v3.0.0.4 need upgrade.
[02094944][11 00][05] v3.9.0.0 -> v3.9.0.0 need upgrade.
[02095043][12 00][05] v1.11.0.0 -> v1.11.0.0 need upgrade.
[02095143][12 01][05] v1.11.0.0 -> v1.11.0.0 need upgrade.
[02095244][12 02][05] v1.11.0.0 -> v1.11.0.0 need upgrade.
[02095344][12 03][05] v1.11.0.0 -> v1.11.0.0 need upgrade.
[02102681][15 00][06] device not detected.
[02102764][17 00][05] v1.1.0.4 -> v1.1.0.4 need upgrade.
[02102884][17 01][05] v2.0.1.4 -> v2.0.1.4 need upgrade.
[02102964][19 00][00] v0.0.0.0 -> v1.0.8.96 need upgrade.
[02103014]Done.
 

New Threads

Members online

Forum statistics

Threads
19,760
Messages
193,097
Members
29,129
Latest member
Dtc6776