Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Gimbal roll reached end postion

Joined
Apr 5, 2022
Messages
25
Reaction score
5
Age
33
Hi.
After flex cable and mainboard replacement my gimbal is dead. Have vision, autofocus, but gimbal wont calibrate or anything. Just saying "gimbal roll reached end position" and its over. No calibration, no moves, no controll. :/
I did fw update. Didnt help. Any ideas?
 
Joined
Apr 5, 2022
Messages
25
Reaction score
5
Age
33
Hi.
After flex cable and mainboard replacement my gimbal is dead. Have vision, autofocus, but gimbal wont calibrate or anything. Just saying "gimbal roll reached end position" and its over. No calibration, no moves, no controll. :/
I did fw update. Didnt help. Any ideas?
Video

 
Joined
Apr 22, 2016
Messages
536
Reaction score
149
Location
Sofia
Website
goldenskybirds.com
It seems like the magnetic nuts need adjustment, every axis have magnetc nut and if it's not perfectly aligned to where it should be the gimbal may be loose like in your video or may act crazy going from end to end fery fast or having something like half movements while initializing.

Check this video at 21:10 he is installing the magnetic nut, note that he marked it with pencil or something prior disassembly so to know the exact position on assembly.

I fixed mine by several slight adjustments, installing the camera on the drone and power up to test. Then again disassemble slight adjust the nut position in the same direction and test again, if not improving try in the oposite direction, there will be a moment when it will start working normally but the camera may not be pefectly paralel to the drone after initialization is finished, with a few more tiny adjustments this could be nailed perfectly. Unfortunatelly this is very tedious process but the good thing is that it's completelly fixable.
 
Joined
Apr 5, 2022
Messages
25
Reaction score
5
Age
33
Ok, I will check it, but dont You think its because mother boards swap? They look the same, but maybe I need to do some adjustments?
 

Attachments

  • PXL_20221104_210639803.jpg
    PXL_20221104_210639803.jpg
    4.5 MB · Views: 1
Joined
Apr 5, 2022
Messages
25
Reaction score
5
Age
33
It seems like the magnetic nuts need adjustment, every axis have magnetc nut and if it's not perfectly aligned to where it should be the gimbal may be loose like in your video or may act crazy going from end to end fery fast or having something like half movements while initializing.

Check this video at 21:10 he is installing the magnetic nut, note that he marked it with pencil or something prior disassembly so to know the exact position on assembly.

I fixed mine by several slight adjustments, installing the camera on the drone and power up to test. Then again disassemble slight adjust the nut position in the same direction and test again, if not improving try in the oposite direction, there will be a moment when it will start working normally but the camera may not be pefectly paralel to the drone after initialization is finished, with a few more tiny adjustments this could be nailed perfectly. Unfortunatelly this is very tedious process but the good thing is that it's completelly fixable.
I didnt even touch roll axis magnetic screw. Yaw axis was 100% set correctly, cause it was marked and I did 6 flex cables replacement, so lets say I am a bit experienced user
 
Joined
Apr 22, 2016
Messages
536
Reaction score
149
Location
Sofia
Website
goldenskybirds.com
I didnt even touch roll axis magnetic screw. Yaw axis was 100% set correctly, cause it was marked and I did 6 flex cables replacement, so lets say I am a bit experienced user
Even previously marked it still needed additional adjustment in my case, also it was on the pan axis the video is just for reference.

Good Luck!
 

New Threads

Members online

No members online now.

Forum statistics

Threads
21,922
Messages
208,711
Members
32,138
Latest member
alexanderandy