Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Help!! Cant log in to DJI Go App

Discussion in 'Inspire 1 Help' started by Positive Image, Dec 9, 2015.

  1. Positive Image

    Nov 7, 2015
    Likes Received:
    I updated to the latest go app version last night and now it wants me to log in, but when i do it asks me to enter a valid email address which I am doing. That in itself is strange because I never log out of the APP
    Ive tried deleting the app and reinstalling multiple time but the same problem persists. (Using my iPad)
    Ive even tried to re-register which i guess isn't a good idea as I would loose all my data, records etc which is on file but it still give me the same email prompt.
    I am still signed in to their forum on my mac and it is saying I am in the US when I was and still am in the UK and its saying Im offline when I'm not.
    I can't get any response from them, anyone had a similar issue / know of a fix.
    I am effectible locked out of my inspire!
    Thank you
  2. The Editor

    The Editor Moderator
    Staff Member

    Aug 7, 2013
    Likes Received:
    It's the hyphen in your email address that is disagreeing with the app.
    Please use a different email address for the time being until a fix is issued.