Welcome Inspire Pilots!
Jump in and join our free DJI Inspire community today!
Sign up

Help connecting DJI go app

Joined
Mar 30, 2015
Messages
707
Likes
147
Age
37
#1
Hi guys,

im trying to use an inspire 1 that I have had parked up for the last three years, I have been charging and discharging batteries etc over that time.
I have it powered up, the remote connects and the light goes green, the camera responds to the wheel and I can start the motors,

But my Iphone is new, so I just downloaded the app DJI go to it, and it wont connect to the inspire, the equpitment page just shows how to connect but wont conenct.
I have checkd the cable is working in itunes,

is there likely some forced update that needs to be done to the aircraft in order to make it work with the latest version of the app ?

if so , does anyone know how i can get an older version of the app, and or a list of what has been updated? Im not one to allow my products to get updated when not neccesary. I recently updated an iphone after two years and the second it completed the update the battery life dropped to 50% and the GPS stopped working.

So im not one for being forced into buying new tech when its not needed.
 
Joined
Jan 13, 2019
Messages
18
Likes
1
Age
62
#2
Hi guys,

im trying to use an inspire 1 that I have had parked up for the last three years, I have been charging and discharging batteries etc over that time.
I have it powered up, the remote connects and the light goes green, the camera responds to the wheel and I can start the motors,

But my Iphone is new, so I just downloaded the app DJI go to it, and it wont connect to the inspire, the equpitment page just shows how to connect but wont conenct.
I have checkd the cable is working in itunes,

is there likely some forced update that needs to be done to the aircraft in order to make it work with the latest version of the app ?

if so , does anyone know how i can get an older version of the app, and or a list of what has been updated? Im not one to allow my products to get updated when not neccesary. I recently updated an iphone after two years and the second it completed the update the battery life dropped to 50% and the GPS stopped working.

So im not one for being forced into buying new tech when its not needed.
I noticed that the older firmware on the bird does not support the new phones maybe try a older phone and or app version ??????
 
Joined
Mar 30, 2015
Messages
707
Likes
147
Age
37
#3
Ah, thats probably the case then , the last time I used it on an iphone 6, no probs, now I have an 8 plus and it doesnt work. The 6 is in another country, and the idea is to see if the inspire is good before taking it there.

I cant download the old app, the DJI app was the first ever thing I downloaded on my apple account, but when I try to download the old version it just installs the current version of the app. maybe I have to update the firmware on the bird
 
Joined
Jan 13, 2019
Messages
18
Likes
1
Age
62
#4
Ah, thats probably the case then , the last time I used it on an iphone 6, no probs, now I have an 8 plus and it doesnt work. The 6 is in another country, and the idea is to see if the inspire is good before taking it there.

I cant download the old app, the DJI app was the first ever thing I downloaded on my apple account, but when I try to download the old version it just installs the current version of the app. maybe I have to update the firmware on the bird
I have FW 1.8 on the bird and if I use old app ver on a new Iphone 10 & 6+ it doesn't work. If I use the new app ver on a new Iphone it works good and If I use the old Iphone 5 and old app ver it works????? Not to sure about flying as of yet but everything else works good. As for the Go app you can get any ver just google (downgrade DJI go app).
 
Joined
Mar 30, 2015
Messages
707
Likes
147
Age
37
#5
Well, I tried an older samsung phone, an edge 6, and it at least vibrates when connected to the remote. The Iphone doesnt even do that, but it still has no connectivity within the app

I may just flash the newest firmware to the bird today and see what happens.
 
Joined
Mar 30, 2015
Messages
707
Likes
147
Age
37
#6
well, i updated the craft fine,
now the RC will kind of connect to the craft, the light flashes red and green, it will control the camera gimbal, but not arm the motors,
And of course, I find that after 1.03 firmware I cannot update the RC through the USB anymore, and the app wont connect, so im fully fu**ed.
I tried holding the "academy" button for ten seconds in the app to being up the controller firmware status, it just says disconnected.
What a POS!!!!!
 
Joined
Jan 13, 2019
Messages
18
Likes
1
Age
62
#7
well, i updated the craft fine,
now the RC will kind of connect to the craft, the light flashes red and green, it will control the camera gimbal, but not arm the motors,
And of course, I find that after 1.03 firmware I cannot update the RC through the USB anymore, and the app wont connect, so im fully fu**ed.
I tried holding the "academy" button for ten seconds in the app to being up the controller firmware status, it just says disconnected.
What a POS!!!!!
Maybe try the DJI assistant program not sure but may be worth a try????
 
Joined
Mar 30, 2015
Messages
707
Likes
147
Age
37
#8
does the assistant app work for the inpsire 1? from what I can see online it does not
 
Joined
Mar 30, 2015
Messages
707
Likes
147
Age
37
#10
thanks, i have done this, the controller will move the camera, but not arm the motors or connect to the app
 

New Threads

Members online

Forum statistics

Threads
18,601
Messages
184,147
Members
27,301
Latest member
Lionskye