Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

I2 firmware update consistently fails at 25%

Joined
Jul 21, 2021
Messages
5
Reaction score
0
Age
48
Hey all I recently replaced my Main Controller (part 24) along with FPV camera and gimbal mount due to IMU failed assisted crash...I'm attempting to wake this thing up and get it back in the air again; but, cant get past 25% on the firmware upgrade. Any and all assistance would be greatly appreciated... also this will be for sale upon successful test flight!
 
Hey all I recently replaced my Main Controller (part 24) along with FPV camera and gimbal mount due to IMU failed assisted crash...I'm attempting to wake this thing up and get it back in the air again; but, cant get past 25% on the firmware upgrade. Any and all assistance would be greatly appreciated... also this will be for sale upon successful test flight!
You attempting this via PC and DJI Asst? If not, I'd download & install newest version for Inspire 2. Plus in Radio and upgrade and plug in I2 to upgrade.
 
You attempting this via PC and DJI Asst? If not, I'd download & install newest version for Inspire 2. Plus in Radio and upgrade and plug in I2 to upgrade.
#1 Yes, tried on a PC using the latest version of DJI assist ensuring I2 was supported on the list.
- my remote is up to date on firmware.
- still no joy on getting past 25% on aircraft.

Other
- I've tried installing all the older versions (stacking)
- tried w/o (X5S) gimbal installed
- IMU calibrated
- I got a "vision system error"
- upon start up and throughout the gimbal is limp/not doing anything, no video feed. FPV camera works fine.

#2 updated from my Go4 app on my crystal sky and it failed around 60%
 
#1 Yes, tried on a PC using the latest version of DJI assist ensuring I2 was supported on the list.
- my remote is up to date on firmware.
- still no joy on getting past 25% on aircraft.

Other
- I've tried installing all the older versions (stacking)
- tried w/o (X5S) gimbal installed
- IMU calibrated
- I got a "vision system error"
- upon start up and throughout the gimbal is limp/not doing anything, no video feed. FPV camera works fine.

#2 updated from my Go4 app on my crystal sky and it failed around 60%
I've taken my Inspire 2's apart a few times to replace the rear battery section, nose fan and a few other issues. After all your diagnostic work, I'd ponder if maybe a MicoConnector not correctly seated or if a connector or ribon end is damaged. I know it's a pain to disassemble and resplit, but have you considered a connection or pinched wire as a possible? Or, always possible... a bad "new" main board.

One I2 of my repairs, the nose fan replacement, I couldn't see any issues but it wouldn't operate correctly. I pulled it back down and rebuilt, being a little more attentive and it behaved nicely on power up.

My Air2S had Ft OA sensors not functional after an arm replacement... ended up being the internal socket of the micro connector had a few prongs bent by not being straight into connector.
 
  • Like
Reactions: psionic001

New Posts

Members online

No members online now.

Forum statistics

Threads
22,292
Messages
210,737
Members
34,491
Latest member
Andrewgogma