Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Inspire 1 Pro - Both Controller Keep Beeping - Tried Everything I know - Help!

Joined
Oct 29, 2020
Messages
3
Reaction score
0
Age
38
Location
London, UK

I just bought this used Inspire 1 Pro with Zenmuse x5 with x2 Controllers (Master And Slave). And tried to Upgrade the firmware, which failed at first attempt, and Since then Its just Constantly Beeping.​


To solve this I tried these Steps :


1. Calibrated both the Controller more then 5 times.

2. Successfully Upgraded and restarted and Downgraded and restarted ; once restarted its start beeping again.

3. Tried Press C1 + C2 + Shutter Wheel + Record Button altogether and Start the Controller. Wait for about 2-3 sec for the "D-DD" (No Sound came for my case) and let all button go and Press the Wheel on the right side of the controller (It's a 'click wheel', similar to a mouse wheel) and then the first light of the controller will become blue and it will constantly beep DDDD.
Then Use a pen to click the linking button on the aircraft and hold for 3-5 seconds, and then take the pen off the aircraft and wait, it will be linked soon.

4. Tried to normally re-link the Aircraft

5. Finally Tried to Fly while the controller Beeps (Everything Works), hoping once its on the Sky it may stop. But No Luck.

6. Called DJI, they just want me to Send it for check and repair, but I have a shoot in 3 days and it Bangladesh and I need to use this.

Please I need All the HELP I can..
Please if you know some other way to stop it then I'll be Saved..


PS: I have never flown this Inspire out side of London Area, so there were always little Cautions the 3 times I flown since I bought it, and I followed all the Rules and Regulations. Can it be because of the Area Im flying ? Surly not .
 
Joined
Mar 20, 2017
Messages
275
Reaction score
84
Location
Arizona
In the controller calibration sequence, it is not uncommon for some to miss the scroll wheel portion of that procedure.
Just a thought.
 
  • Like
Reactions: Sarkar

New Threads

Members online

Forum statistics

Threads
20,951
Messages
202,037
Members
30,633
Latest member
felixfrischeisen