Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

No Inspire 2 map with cendence and Crystal Sky

May 7, 2017
Reaction score
I've been flying my Inspire 2 a little and I believe it is all updated. My crystal sky is for sure.

When I turn it on there I have the black map box and it doesn't register "home point updated check map".

So I watched the video of how to get an offline map hit the 3 dots, went to offline maps, wifi on and I get no map there either. It just spins until the monitor turns itself off.

Any ideas on how to fix this problem?
Without more information, I'm going to put the blame square on your Internet connection. From here, you should run more "common sense" tests to eliminate the obvious...like Internet connection. List your troubleshooting regimen in your next post.


I tried forgetting my internet connection and then re-signing in. tried it with a different network. Crystal sky is signed in. I only have 5.2 Ghz wireless here. four orbi range extenders gets me remote cameras inside the chicken coop. The rather large Mavic 3T update went in no problem this morning when signed in to the network.

Crystalsky monitor is now 8 feet from the wireless router. I do have slow internet here download speed is 26.9Mbps and upload is 5.94 Mbps. But usually everything works.

I updated the I2 to the latest firmware a week ago using the USB connection method.

Other drones Inspire 1, Mavic 2 pro and mavic 3t are getting maps no problems. Litchi is working on the Inspire 1 Mavic 2 pro.

Crystal Sky monitors are up to date. Although I did download litchi on to them lately. But the map on the Inspire 2 was gone before that.

I have turned dji go off and on many times. Turned on and off and rebooted the crystal sky(s) many times. tried the high definition large one and the low definition large one. Tried the smaller crystalsky.

Crystal sky says it is connected to the network and system check comes up latest firmware. I get this screen and select off line maps:

Then it just spins on this screen until every thing shuts down on this screen:


I tried it with the smaller crystalsky and get to this screen:


Thanks for looking. Not sure what else to try. These are all not connected with the drone. I tried hitting download on the little screen and I do get a networ4k connection error check internet but it says it is connected when I look in the settings.


  • IMG_2280.jpg
    2.5 MB · Views: 1
  • IMG_2281.jpg
    2.1 MB · Views: 1
Last edited:
I haven't found any solutions so far. I tried to see if Inspire 2 was supported on Litchi as a possible end around, but I couldn't confirm if that would work with I2 or not. So at present I am flying other drones. I haven't tried it on the standard controls That was going to be my next try thinking it was something in the Cendence. Did yours just start doing it? I am not sure if we can back grade the software on the I2. I feel like I am flying blind without that map and not knowing if the return to home point is correct.
FIXED: I had the exact same "no offline maps" problem on both my Crystal Sky monitors and was able to fix it with help from the kind folks at DJI. I thought I had all the firmwares updated already, but they gave me a different method to upgrade the CS firmware and it worked on both monitors.

Here is the email they sent me with instructions for the fix: Good Luck.

DJI Support (DJI Support)
2023/3/14 GMT+8 21:08
Hi Cliff,

If you are using Crystalsky, please follow the method below.

Please download the app installation package from this link. https://pan-sec.djicorp.com/s/ktdbsDFxwg6YerS

Then put this APK file on a SD card. Insert the SD card on the CrystalSky and then find it in the CrystalSky's file manager, then install this app. Then please check the offline function again.

Due to some reasons, we have to change the map service provider from Mapbox to maptiler. So mapbox offline map is not available on your DJI Go 4. Therefore, we have to update it in this way, even the firmware of the crystalsky is up to date.

Please give it a try and let me know if it works.

Thank you.

Take care and stay safe.
I had a problem with my CS's after a firmware update and. Last year DJI sent out the following:

"DJI always continues to iterate and release more advanced product functions. To provide a better service experience, we will soon update the map services for some apps. It is recommended to update the app/remote controller before November 25, 2022, to continue to benefit from regular feature updates and performance improvements. Continuing using older versions of the DJI app will negatively impact map display. We apologize for any inconvenience you may experience."

DJI GO 4 has to be Version 4.3.54. In my case Litchi loaded maps and updated DJI Pilot loaded maps. As I found out I couldn't update my crystal sky's to DJI GO 4 V4.3.54 with the apk that's available on the DJI website. I subsequently found a post describing the problem. The author of the post contacted DJI support and received an DJI GO 4 V4.3.54 apk that updated the crystal sky and maps loaded. If you are operating DJI GO 4 at a level lower than V4.3.54, it is my experience mapbox maps will not load. My crystal sky's worked fine until I lost the maps cached in the Crystal Sky's. If you need to update to V4.3.54 I'd suggest contacting DJI support. After several communication's with support, they sent me a tailored DJI GO 4 that loads maps on my I2 and MP2.

Hope this helps.
Awesome. Thank you sooo much for the help. I just contacted DJI support online at 9:30 EST on a Sunday and she recognized the problem and gave me the latest fix information. Today is a great day!
Just flew the I2 and the update from DJI support fixed the issue! Its been mothballed so I need to get familiar with it again and maybe a new set of batteries.

Members online

Forum statistics

Latest member