Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Phantom 3 Standard

Joined
May 3, 2014
Messages
55
Reaction score
9
Location
New Zealand
Before you all tell me this is an Inspire forum, I have an Inspire and after updating to Go app with the new (Inspire) firmware, I can "enter camera view" for a Phantom 3 Standard as shown in bottom pic. but I do not get that option for my Inspire
The top pic does not have the "enter camera view" option, and for the life of me can't figure out what to do.
DJI support tell me my Samsung S8.4 is not a compatible device,. I know it's not great but it has worked so far.
Am I having a senior moment or what?
Have tried the USB stick way to update RC, but nothing happens. Can't update through the Go app as DJI suggest because of this problem. So RC is not updated but I can't see why that would cause/contribute to this problem.
Have followed all the steps, in order, on "how to connect".
Suggestions please.


Inspire screen shot 1.jpg Inspire screen shot 2.jpg
 
Last edited:

New Threads

Forum statistics

Threads
19,383
Messages
190,132
Members
28,742
Latest member
InaUav