Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Possible defective cable in Remote Controller? (App partially working)

Feb 13, 2016
Reaction score
Hi all,

This is for those who have partial app problems. Video feed works but not able to set features like altitude or distance, gimbal modes, read the MODS, etc.

My title reads "Possible" because it could be isolated, meaning that whoever manufactured these parts may have had a bad batch that passed quality control. Quality control usually only test parts at random.

I've read in other places where other Inspire 1 owners are having this same problem with the same symptoms.

I just bought an Inspire 1 Pro in Feb, 2016.

I was able to update the firmware without issue and everything worked great! I made three flights with great results.

I've been flying an S800 and S1000 for quite a while, I've had the S800 for over four years and it's still going strong, never crashed either one. I have had to replace some worn parts here and there but that's to be expected.

During a preflight inspection before my fourth flight, I noticed that there were no Gyro or GPS MOD numbers at all. I had video feed but there were rolling black lines in it. Battery info and a few other things were there but I also noticed that the camera didn't make the usual sounds that it makes when changing gimbal modes or when it's calibrating.

Several commands would "Timeout" and I couldn't switch to any of the gimbal modes like Free or FPV, it defaulted at Follow. It wouldn't allow me to pan the camera either.

C1 and C2 buttons were stuck on camera settings.

I called DJI support in North America and they said that it sounded like a software problem in the app. The only way to check that is to have DJI support in China go through the backdoor of the app to see if the software was corrupt (DJI Cloud portion). I couldn't just uninstall the app and reinstall it (I did try three times anyway). This is a portion of the app that's in the DJI Cloud (the part you use to sync your flight data and other stuff like photos and video).

After having to give them my serial numbers, purchase date and other info, they checked and said that the software was not corrupt. It must be my tablet or the USB to Lightning cable.

I tried other tablets (borrowed from friends), tried other USB to Lightning cables but no luck at all. It continued to be the same problem everytime.

Just an FYI: When you create a DJI Cloud Account to store YOUR flight data, photos, videos, etc, they also store the software for YOUR app. They said that they do this in case someone's tablet corrupts the software, it wouldn't corrupt it for everyone, just you. So, you may want to see if that's the problem before sending the controller in for repair. This has to be checked through China's DJI Support.

Then I was told that I would have to send the remote in to DJI for diagnosis and repair but it could take from two to four weeks to get it back. I'm leaving on a cross country trip in 10 days and I really want to take my new Inspire with me. I was not interested in taking either one of my large drones.

I'm an electronics technician and I did a little research on YouTube to see if there were any videos of the inside of the remote so I would know what I was getting into before I took it apart.
(I'm also a machinist but I have to work on machine electronics and control systems at times so I studied for quite a while to add electronics tech work to my list of things I could do).

Yep, I know this could void the warranty but what the heck. I was told that the only part that it would void would be the transmitter.

After opening it up (which was pretty straight forward), I did an extensive visual inspection of the board with the microscope, then I decided to test the ribbon cable from the main board to the connector board (the board that's on the back where you plug your standard size USB, mini HDMI, CAN Bus and micro USB cables in at).

I had to use my electronics boom microscope again to be able to see the tiny contacts on that ribbon cable. Then I had to file down a set of leads from my continuity tester to be able to test the contacts. I touched the leads of my continuity tester just behind the little white line on the ends of the cable to prevent damage to the part of the contacts that go into the socket strips for the cable (they are very soft because they are very thin and you could damage that part of the cable).

Alas, I found that the third contact from the left as you are facing the back of the transmitter was not testing good, it had a break in it. I tested each contact carefully three times to confirm my findings.

I called DJI back and asked if they could send / sell me a new cable but they said that I'd still have to send it in. They will NOT sell you parts for any of the electronics, period!, it's a policy of theirs.

After thinking about what I could use as a "Jumper wire", I came up with the idea of using a special silicone wire meant for use with the AlexMos gimbal controllers (I have some left over from another gimbal project because I made my own brushless gimbals for the large drones).

After very careful consideration, I determined that there was no way for me to solder anything because the contacts on the socket strip portions that are already soldered to the boards are way to small for conventional soldering equipment.

I had to cut away all but three strands of wire on each end to be able to fit the wire into the tiny, tiny holes in the little black locking tab that locks the ribbon cable in place.

Under the microscope, I was able to insert the wire into the tiny holes, then engage the clamping tabs which held the wire tightly against the contacts.

After installing the jumper wire, I tested it to make sure there were no shorts in the contacts next to the bad one, I applied some liquid electrical tape to the ends and the insulation to make sure that they would not move,

After holding my breath briefly, I hooked up my iPad, turned everything back on and it "WORKED" again, just like it did when I first got it. Hoo Blanking Rah!!! :)

None of the standard authorized repair centers are allowed to repair the remote controllers, they don't even have parts for the insides of them. They all told me that I had no choice but to send it to DJI's repair center if I needed parts for it.

I was finally able to speak with one of the repair technicians at DJI. I told him exactly what I found and exactly what I did to fix it and this is what he replied: "That's great that you were able to fix it yourself!, but.......Yeah, unfortunately, the third contact on that ribbon cable seems to always be the one that goes bad. We have to repair several a month for that same reason". :-O

The repair tech also said that they have installed new ones that were bad and sometimes have to keep trying cables until they find one that works.

The tech asked me not to mention his name so I'm sure he wasn't supposed to tell me what he told me.

Note: It could be that this repair center could have received part of the possible bad batch of cables?

I won't blame DJI for a flaw in the design since I have no way to prove or disprove it.

I asked if DJI was going to make a new design of that ribbon cable or check into a possible manufacturer issue but he didn't know if they were or not. I can only imagine that they would do something since they are having to repair too many of them with that same problem. I'm sure they would want to reduce their repair costs.

So, if you have this issue and you can't fix it with a new USB cable or a different tablet and you are sure that the app software is not corrupt, it very well could be that ribbon cable is bad.

Keep in mind that this does not cause you to lose control of your Inspire, it will still fly just fine but some features may not work anymore. I say this because if it happens in flight, you can still land it safely. The aircraft retains all of the flight settings including the home point but not the gimbal, altitude and distance settings.

Keep in mind that the failsafe altitude MAY not be retained (I don't know about that part, I didn't dare try it).

You can't check the MODs or calibrate the IMU and you can't initiate GPS calibration while having this problem.

If you are having this same problem, I don't recommend flying until it's fixed.

After testing the Inspire handheld with the motors running with no props, I was able to determine that the IMU still corrected for level flight and took the control commands from the transmitter like it should. I decided that it was safe to take it up for a short flight but never tried the RTH feature cause I was afraid it might not have a safe RTH altitude recorded. This test let me know that if it happened in flight, I would still be able to fly it long enough to land it safely as long as I didn't lose the control signals. The failsafe MAY still work but again, I don't know that for sure.

This was driving me up the wall till I was able to figure it out so I hope this information helps those who have this problem.

If you're not absolutely sure that you can fix it yourself, please send it to the DJI Repair Center. Maybe they will have a better version of that cable so it's not a problem anymore.

Just remember, if you do want to try to fix it yourself, those contacts are so tiny and close together that a normal pointed tester lead will touch two contacts at one time unless you file the lead (metal part) to a fine point. I'm amazed how they can make micro, micro parts like that. The only way is to use micro robot arms that are precise to a 1/10 of one thousandths of an inch. The contacts on that cable are only about .018" wide each (18 thousandths of one inch wide, that's breaking up 1 inch into 1000 segments and these are only 18 of those one thousand segments, this info is for those who don't normally deal with such small measurements).

Good luck!!

BTW, Everything else about this new drone "Rocks!" :)

I REALLY like it!!! :)

All the best,

Last edited:

Members online

Forum statistics

Latest member