Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Firmware V01.08.01.00 required

Joined
Mar 23, 2019
Messages
55
Reaction score
26
Age
47
I'm in the process of rolling back my I1V2 firmware to V01.08.01.00. The I1V2 is used with both the the X3 and X5 cameras. I use the X3 camera exclusively for the firmware flashes as there seems to be issues at times using the X5 camera for this.

The aircraft FW was on the latest when I started. So this has been my progression: WM610_FW_V01.11.01.50+ -> WM610_FW_V01.10.01.40 -> WM610_FW_V01.09.01.30 and the FW the aircarft is on right now is v1.9.1.30 as from the Go app. I'm trying to roll back to V01.08.01.00, but I keep on getting stuck on the downgrade from WM610_FW_V01.09.01.30 -> WM610_FW_V01.08.01.00.

I've tried the DEBUG file, I've tried forcing the firmware flash with the red bind button, which have worked with all other firmware flashes, just not this one. All I can think is that the WM610_FW_V01.08.01.00.bin files I have been able to get are somehow damaged.

I've tried files from:
Of course DJI no longer publicly hosts this bin file for the Inspire 1, so I can't get it there either.

I'm appealing to the community here, to someone who has an original WM610_FW_V01.08.01.00.bin file that they know is working fine (have flashed it to their aircraft without issues of any kind) to kindly PM me a link to a WeTransfer / DropBox or similar link where I can download this.

Appreciated!
 
  • Like
Reactions: Rattydude77
Joined
Jun 28, 2016
Messages
1,380
Reaction score
589
Age
57
I'm in the process of rolling back my I1V2 firmware to V01.08.01.00. The I1V2 is used with both the the X3 and X5 cameras. I use the X3 camera exclusively for the firmware flashes as there seems to be issues at times using the X5 camera for this.

The aircraft FW was on the latest when I started. So this has been my progression: WM610_FW_V01.11.01.50+ -> WM610_FW_V01.10.01.40 -> WM610_FW_V01.09.01.30 and the FW the aircarft is on right now is v1.9.1.30 as from the Go app. I'm trying to roll back to V01.08.01.00, but I keep on getting stuck on the downgrade from WM610_FW_V01.09.01.30 -> WM610_FW_V01.08.01.00.

I've tried the DEBUG file, I've tried forcing the firmware flash with the red bind button, which have worked with all other firmware flashes, just not this one. All I can think is that the WM610_FW_V01.08.01.00.bin files I have been able to get are somehow damaged.

I've tried files from:
Of course DJI no longer publicly hosts this bin file for the Inspire 1, so I can't get it there either.

I'm appealing to the community here, to someone who has an original WM610_FW_V01.08.01.00.bin file that they know is working fine (have flashed it to their aircraft without issues of any kind) to kindly PM me a link to a WeTransfer / DropBox or similar link where I can download this.

Appreciated!
The Panorobot are the files I used to successfully roll back 3 Inspire 1 drones:

Inspire 1 V1
Inspire 1 V2
Inspire 1 Pro

I would stick with the Panobot .bin file. I think you're barking up the wrong tree by blaming the .bin file. It would be better to post a detailed personal log of your roll back process (video would be WAY better). At this point it's impossible to determine the point of failure because we have no idea your regimen. You seem like a diligent sort, so I would honestly make a video. Talk the to the camera. Spare no detail. Show your computer screen so we can see your files. Show the drone during the roll back process. Like I said, spare no detail.

D
 
  • Like
Reactions: Jim Weist
Joined
Mar 23, 2019
Messages
55
Reaction score
26
Age
47
The Panorobot are the files I used to successfully roll back 3 Inspire 1 drones:

Inspire 1 V1
Inspire 1 V2
Inspire 1 Pro

I would stick with the Panobot .bin file. I think you're barking up the wrong tree by blaming the .bin file. It would be better to post a detailed personal log of your roll back process (video would be WAY better). At this point it's impossible to determine the point of failure because we have no idea your regimen. You seem like a diligent sort, so I would honestly make a video. Talk the to the camera. Spare no detail. Show your computer screen so we can see your files. Show the drone during the roll back process. Like I said, spare no detail.

D
Hi Donnie, we've run through this via PM before. However, for the benefit of the forum (and hopefully myself), I'll run through it again.

  • Aircraft (Inspire 1 V2) off. Controller & iPad off.
  • Aircraft battery full. Have not attempted FW flash with battery at or below 50% charged.
  • MicroSD Card in MicroSD Adapter (as previously formatted by the aircraft) into PC.
  • Copy WM610_FW_DEBUG file to SD Card. (Debug files named WM610_FC350_FW_DEBUG or WM610_FC550_FW_DEBUG do not work.)
  • Copy .bin file to SD Card. FW file needs to be named INMCAPPFw1.bin to work. FW files named in format (examples hereafter for v1.11 version) WM610_FW_V01.11.01.50.bin also works. FW files named in format WM610_FC350_FW_V01.11.01.50.bin or WM610_FC550_FW_V01.11.01.50.bin do not work to flash to v1.11 version (for example).
  • Eject command on PC for MicroSD Adapter with MicroSD card, take out card.
  • Insert Micro SD card into Zenmuse X3 Micro SD card slot.
  • Find bind button, press and hold bind button.
  • Double tap battery to start aircraft, still holding bind button depressed.
  • Release bind button once I hear the D-D-D-D sound.
  • Let the flashing process run until I hear the repeated D-DD sound, I let it run for a few minutes (approx. 2-3 min.) longer.
  • Double tap battery to switch off the aircraft.
  • Remove Micro SD card from Zenmuse X3 camera and put into Micro SD Adapter.
  • Check the SD card in PC. More often than not the log file doesn't say "success" even though the process has ended (D-DD sound) and the version on the Go app indicates that the FW flash has been successful. (This is my experience when downgrading to v1.10 from v1.11+).

The above has worked when flashing firmware WM610_FW_V01.11.01.50+ / WM610_FW_V01.10.01.40 / WM610_FW_V01.09.01.30 but won't work for firmware WM610_FW_V01.08.01.00.

I've tried using multiple configurations of the debug file naming and the FW file naming, it only works as indicated above.

I've tried flashing firmware WM610_FW_V01.08.01.00 without holding the red bind button (relying on the DEBUG file only), doesn't work then either. I prefer using the red bind button method as it saves time in having to redo a few steps if the attempted flash doesn't work out for some reason. Success rate with the red bind button is very high in upgrading or downgrading firmware (apart from firmware WM610_FW_V01.08.01.00).

I've tried letting the firmware WM610_FW_V01.08.01.00 flash "cook" for 40 minutes (it could have been a little longer, definitely not shorter), it doesn't finish, it keeps making an unchanging sound once the process commences. See the ZIP file here attached for a 10 second MP4 clip on aircraft sound during flashing with firmware WM610_FW_V01.08.01.00, apologies for the sound quality, turn up the sound to hear clearly what the aircraft is doing. The X3's whine has higher pitch than normal and doesn't have interruptions, it's like the fan X3's fan is going full blast. Fortunately these erroneous FW flashes hasn't bricked the aircraft or damaged the X3, but I don't want to tempt fate...

Some extra info, should it matter:
  • Go app version 3.1.64
  • Controller version 1.7.80
Neither the Go app or the controller is switched on during the firmware flash operation.

Steve Barnes also suggested I make the LOG.TXT file below available, but hasn't commented on it yet (FaceBook DJI Modding Lounge thread). so if you know how to read this, good for you! Please enlighten us!

So, if anyone has an idea or can help out, feel free to comment.
 

Attachments

Last edited:
Joined
May 22, 2019
Messages
13
Reaction score
5
Age
57
Hi Donnie, we've run through this via PM before. However, for the benefit of the forum (and hopefully myself), I'll run through it again.

  • Aircraft (Inspire 1 V2) off. Controller & iPad off.
  • Aircraft battery full. Have not attempted FW flash with battery at or below 50% charged.
  • MicroSD Card in MicroSD Adapter (as previously formatted by the aircraft) into PC.
  • Copy WM610_FW_DEBUG file to SD Card. (Debug files named WM610_FC350_FW_DEBUG or WM610_FC550_FW_DEBUG do not work.)
  • Copy .bin file to SD Card. FW file needs to be named INMCAPPFw1.bin to work. FW files named in format (examples hereafter for v1.11 version) WM610_FW_V01.11.01.50.bin also works. FW files named in format WM610_FC350_FW_V01.11.01.50.bin or WM610_FC550_FW_V01.11.01.50.bin do not work to flash to v1.11 version (for example).
  • Eject command on PC for MicroSD Adapter with MicroSD card, take out card.
  • Insert Micro SD card into Zenmuse X3 Micro SD card slot.
  • Find bind button, press and hold bind button.
  • Double tap battery to start aircraft, still holding bind button depressed.
  • Release bind button once I hear the D-D-D-D sound.
  • Let the flashing process run until I hear the repeated D-DD sound, I let it run for a few minutes (approx. 2-3 min.) longer.
  • Double tap battery to switch off the aircraft.
  • Remove Micro SD card from Zenmuse X3 camera and put into Micro SD Adapter.
  • Check the SD card in PC. More often than not the log file doesn't say "success" even though the process has ended (D-DD sound) and the version on the Go app indicates that the FW flash has been successful. (This is my experience when downgrading to v1.10 from v1.11+).

The above has worked when flashing firmware WM610_FW_V01.11.01.50+ / WM610_FW_V01.10.01.40 / WM610_FW_V01.09.01.30 but won't work for firmware WM610_FW_V01.08.01.00.

I've tried using multiple configurations of the debug file naming and the FW file naming, it only works as indicated above.

I've tried flashing firmware WM610_FW_V01.08.01.00 without holding the red bind button (relying on the DEBUG file only), doesn't work then either. I prefer using the red bind button method as it saves time in having to redo a few steps if the attempted flash doesn't work out for some reason. Success rate with the red bind button is very high in upgrading or downgrading firmware (apart from firmware WM610_FW_V01.08.01.00).

I've tried letting the firmware WM610_FW_V01.08.01.00 flash "cook" for 40 minutes (it could have been a little longer, definitely not shorter), it doesn't finish, it keeps making an unchanging sound once the process commences. See the ZIP file here attached for a 10 second MP4 clip on aircraft sound during flashing with firmware WM610_FW_V01.08.01.00, apologies for the sound quality, turn up the sound to hear clearly what the aircraft is doing. The X3's whine has higher pitch than normal and doesn't have interruptions, it's like the fan X3's fan is going full blast. Fortunately these erroneous FW flashes hasn't bricked the aircraft or damaged the X3, but I don't want to tempt fate...

Some extra info, should it matter:
  • Go app version 3.1.64
  • Controller version 1.7.80
Neither the Go app or the controller is switched on during the firmware flash operation.

Steve Barnes also suggested I make the LOG.TXT file below available, but hasn't commented on it yet (FaceBook DJI Modding Lounge thread). so if you know how to read this, good for you! Please enlighten us!

So, if anyone has an idea or can help out, feel free to comment.
When I downgraded my inspires from fw 1.11 to fw 1.08 I didn't do the inbetween fw's I went straight to fw 1.08 with the magic debug file and it worked fine for the x3, z3 and x5 cameras
 
  • Like
Reactions: Donnie Frank
Joined
Mar 23, 2019
Messages
55
Reaction score
26
Age
47
When I downgraded my inspires from fw 1.11 to fw 1.08 I didn't do the inbetween fw's I went straight to fw 1.08 with the magic debug file and it worked fine for the x3, z3 and x5 cameras
Yeah, I tried that initially. The only way the downgrade seemed to want to work was doing it one version at a time, either way it shouldn't make a difference as the FW is being overwritten. Care to share your v1.08 FW bin file with me so I can test and see if this was the problem, or eliminate bad v1.08 FW as a troubleshooting point??
 
Joined
May 22, 2019
Messages
13
Reaction score
5
Age
57
Yeah, I tried that initially. The only way the downgrade seemed to want to work was doing it one version at a time, either way it shouldn't make a difference as the FW is being overwritten. Care to share your v1.08 FW bin file with me so I can test and see if this was the problem, or eliminate bad v1.08 FW as a troubleshooting point??
No problem at all , let me know how to send it to you.

I've tried to upload the zipped fw bin file but it says its too big

This is the you tube video i followed and part 2 of it and all worked well for me.

Part 1 ...

Part 2 ...

Hope it helps
 
Last edited:
  • Like
Reactions: _juju_
Joined
Mar 23, 2019
Messages
55
Reaction score
26
Age
47
Joined
Mar 23, 2019
Messages
55
Reaction score
26
Age
47
Success! Flashed to WM610_FW_V01.08.01.00 !

Thanks for the help with the bin files people.
 
Joined
Mar 23, 2019
Messages
55
Reaction score
26
Age
47
Sweet! What did you change that made it work this time?

D
The firmware file used. It also seems that there must be some internal differences to an aircraft that started out as an I1V2Pro to one started out as an I1V2 (standard / non Pro) to which the X5 camera was just added later to function as the Pro does; the new WM610_FC550_FW_V01.08.01.00.bin file (which is for the Pro) didn't want to take either, even if the "_FC550" part was manually removed from the file name. The new WM610_FW_V01.08.01.00.bin file (which is for the standard / non Pro) stuck though. CARTWHEELS!!

Now onto the next step, locking down the Go app.
 
Last edited:
  • Like
Reactions: Donnie Frank

New Threads

Members online

Forum statistics

Threads
20,558
Messages
199,034
Members
30,110
Latest member
Gradus100