Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Gimbal Extension cable not working with X5

Joined
Jun 13, 2017
Messages
2
Reaction score
0
Age
46
Hello fellow pilots,

I am trying to mount my X5 camera to to a car and control from the inside of the car with the gimbal extension cable (DJI Part 89).

It seems to establish a connection between the camera and DJI Go app and I can control the gimbal but I'm only getting a black screen.

Does anyone else have this problem? Imnrunning the latest pro firmware updates and the X5 works fine with the Osmo without the extension cable.

Do they make a specific cable just for th X5? Any feedback is much appreciated.

Thank you.

Robkn
 
Hello fellow pilots,

I am trying to mount my X5 camera to to a car and control from the inside of the car with the gimbal extension cable (DJI Part 89).

It seems to establish a connection between the camera and DJI Go app and I can control the gimbal but I'm only getting a black screen.

Does anyone else have this problem? Imnrunning the latest pro firmware updates and the X5 works fine with the Osmo without the extension cable.

Do they make a specific cable just for th X5? Any feedback is much appreciated.

Thank you.

Robkn
As we are talking about the Osmo here (since you mention part 89) I have moved this to the relevant section.
 
@rokus212, we've seen a total of two faulty/DOA Part 89 Extension Cables for the Osmo that we've exchanged due to similar reports to yours. Have you had your extension working at all since you purchased it?

It is the same extension for both the X5 and X5R.

Have you tried the handy dandy trick of completely removing your GO App and then installing a new clean version?
 
  • Like
Reactions: The Editor
@rokus212, we've seen a total of two faulty/DOA Part 89 Extension Cables for the Osmo that we've exchanged due to similar reports to yours. Have you had your extension working at all since you purchased it?

It is the same extension for both the X5 and X5R.

Have you tried the handy dandy trick of completely removing your GO App and then installing a new clean version?

It definitely establishes a connection with my X5 as I can control the control the gimbal with both the app and the "joystick" and see the histogram info - but it's just a black screen.
 
It definitely establishes a connection with my X5 as I can control the control the gimbal with both the app and the "joystick" and see the histogram info - but it's just a black screen.

Are you sure you connections are not just dirty on the camera/ osmo. Our Osmo black screens one in every 5 turn on's with our x5r.
 
We had issues on a few occasions with ours and 3 things solved the issue.

1. Using a smaller cable to establish connection first then going on to the longer cable straight after as it would not connect with the longer cable first go.
2.Making sure everything has the latest FW as ours would not work without it.
3. We had to get a new x5r adapter as they wear out pretty easily it seems. We got a re-con camera from Dji and it would not work without a new x5 adapter too.

If you suspect your adapter if playing up try using a pencil rubber to clean the contacts and see if it solves the issue. Also check the pins are still moving when compressed.

Despite the fixes we did still find that sometimes the osmo needed a restart to get going again though sadly...Dji all over.

I hope this gets you going.

Mick
 
Hee Mick,

Thank you for this long open answer, I have a few followup questions:
A. For your point 1. = Where to find a smaller Remote Extension (Part 89), or did you cut yourself to size?
B. If it is not to big of a hassle to find out, which versions are you running?
C. Without the Remote Extension (Part 89) on the x5 adapter, the video feed works. But after I put the expansion part on and power on, no video feed on the screen, but i do have full controll.

Thanks for your answers!!

Huub.
 
Hee Mick,

Thank you for this long open answer, I have a few followup questions:
A. For your point 1. = Where to find a smaller Remote Extension (Part 89), or did you cut yourself to size?
B. If it is not to big of a hassle to find out, which versions are you running?
C. Without the Remote Extension (Part 89) on the x5 adapter, the video feed works. But after I put the expansion part on and power on, no video feed on the screen, but i do have full controll.

Thanks for your answers!!

Huub.

I am not sure as regards software version pal sorry as im selling up. If i get a chance i will check it for you.

But you must power the unit on with the hardwire adapter on and a normal mobile charger length cable (1m roughly). Once its on and your on the go app screen to click on the osmo get the extension ready and quickly break the circuit and add the extra wire in. You should see the osmo re appear in Dji go as the connected device. You can also connect using a short lead, go into Dji go for the camera and then break the circuit and connect the longer lead.

Depending on how your device is set you should get a message about allowing Dji to use the usb device. I always got the option to connect using DjiGo or Dronedeploy and manually chose which one i wanted each time to stop it blocking one or other out. You may have to change your usb settings if it is automatically dismissing it.

Let me know how you get on with this.

Thanks
Mick
 
With 'break the circuit' you mean while the osmo is powered on en connected, remove the camera and ad the the extender cable in between? Isnt' this dangerous, if you mis alinea the camera with the camera mount it can lead to a short circlet right?

So we are on the same page:
- extender cable = https://www.amazon.com/DJI-OSP89-Osmo-Gimbal-Extension/dp/B01MXD05Q5
- "You can also connect using a short lead" = you main the mobile charger cable, because i can not find a shorter omso extender cable.
- Did you change the usb settings to get the hardwire adapter working?

Thanks!
Huub
 
With 'break the circuit' you mean while the osmo is powered on en connected, remove the camera and ad the the extender cable in between? Isnt' this dangerous, if you mis alinea the camera with the camera mount it can lead to a short circlet right?

So we are on the same page:
- extender cable = https://www.amazon.com/DJI-OSP89-Osmo-Gimbal-Extension/dp/B01MXD05Q5
- "You can also connect using a short lead" = you main the mobile charger cable, because i can not find a shorter omso extender cable.
- Did you change the usb settings to get the hardwire adapter working?

Thanks!
Huub

I am sorry we are on crossed wires here. I thought you were referring to the extension lead like this one...

dji x5 hard wire adapter - Google Search:

On this setup i have a small usb lead and a long one and the x5 wont power on with the long lead right off the bat (maybe voltage drop on signal) but does if you plug the small hardwire lead in and then unplug it and plug the extension in.

If you are having issues with the extender you have i would most likely guess the connections are faulty. Do you have a local Dji centre to visit?

In all honesty ive had quiet a few faulty parts off Dji and usually ended up at the local centre trying new parts in the system until the issue is cured. Thats how we found out our black screen issues came from the x5 osmo adapter. You sp=yptoms are similar so i would suggest it might be a similar issue.

Clean all your contacts with a pencil runner on the camera and osmo end as well as the extension on booth ends and see if it works. I have never used one so dont know the start up procedure sorry.
 
To my knowledge, the camera extension cable only works with the X3 camera (not X5). Whenever I use my OSMO Pro, if I want to mount a camera via the extension cable, I have to pull of my X5 (leaving the X5 adapter on the handle) and use my X3.
 
True, X5 and X5R are not compatible with extension cords; either the DJI extension, or the Kamerar versions (pole or cord). I own the X5R and both Kamerar extensions, and they sometimes connect, but cannot maintain recording.
 

New Posts

Members online

No members online now.

Forum statistics

Threads
22,334
Messages
210,842
Members
34,935
Latest member
liamjames