Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

i2 Charge Case 'Discharge Failure'

Joined
Oct 25, 2021
Messages
3
Reaction score
0
Age
38
Discharge Failure- Has anyone had this happen on their charge case? (see pics)
I’ve been using mine for several years with no issues - suddenly today it throws up all these errors.
The discharge fans are running as normal, and the batteries which don’t have an error show a discharge rate of 0.0A.
Really weird. How can this be fixed?
Is it possible to do some sort of factory reset on the case?
 

Attachments

  • IMG_2216.jpg
    IMG_2216.jpg
    783.9 KB · Views: 3
  • IMG_2218.jpg
    IMG_2218.jpg
    588.5 KB · Views: 3
Joined
Mar 22, 2017
Messages
198
Reaction score
97
Age
55
Discharge Failure- Has anyone had this happen on their charge case? (see pics)
I’ve been using mine for several years with no issues - suddenly today it throws up all these errors.
The discharge fans are running as normal, and the batteries which don’t have an error show a discharge rate of 0.0A.
Really weird. How can this be fixed?
Is it possible to do some sort of factory reset on the case?
Never saw that before. I use mine several times a week to charge/discharge batteries. Same thing with just one set in? Does it charge a set?
 
Joined
Oct 25, 2021
Messages
3
Reaction score
0
Age
38
Never saw that before. I use mine several times a week to charge/discharge batteries. Same thing with just one set in? Does it charge a set?
It does charge, yes. And yep it has the same issue if trying to discharge only one set - have also tried in all the different ports.
Perhaps some part of the discharge circuitry has been damaged / dislodged? (not the fan part clearly)
Has anyone disassembled their case before- if so do you think something like this will be easy to spot?
thanks
 

New Threads

Members online

Forum statistics

Threads
21,486
Messages
205,892
Members
31,298
Latest member
ccilogistics