Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

One of my batteries is causing problems

Discussion in 'Inspire 1 Discussion' started by Jesse Rockwell, Nov 28, 2015.

  1. Jesse Rockwell

    Sep 24, 2015
    Likes Received:
    Hi there. A client recently agreed to purchase two TB48 batteries for a job i just shot, which went fantastically.

    All the batteries worked fine, and I was glad to have four, as I used them all.

    This morning when I booted up the Inspire, one of the new TB48s caused the craft to make the beeping and whirring noises I would associate with a firmware upgrade. The battery lights (on the battery itself) were flashing strangely, but the craft was flashing green, and the app said safe to fly GPS. I let it go for 10 minutes (As the beautiful sunrise unfolded), and gave up and powered the craft down.

    I inserted another TB48, and everything worked fine... This really confused me.

    What is going on?
  2. Webeflyin

    Nov 15, 2015
    Likes Received:
    I unfortunately cannot offer help but I was just about to make a thread with a similar issue. One battery has perfectly normal operation and the other not so. When I put the Inspire into travel mode with the gimbal off the landing gear goes all the way up (not stoping at the travel mode position) and then the belly of the inspire touches the ground and then resets it self to legs all the way back down. Again the other battery does not do this so assuming the issue lies within the battery
  3. The Editor

    The Editor Moderator
    Staff Member

    Aug 7, 2013
    Likes Received:
    What firmware was on the batteries?
    You have done battery firmware upgrades before yes?
    You have read the manuals regarding firmware upgrades applicable to aircraft, remote AND batteries?
    Did you still have the firmware .bin file on your MicroSD card in the csmera?
  4. Kilrah

    Feb 3, 2015
    Likes Received:
    Did you try that battery again since? It might just have updated itself, and all you needed was a power cycle once it was done.

    Envoyé de mon SM-G920F en utilisant Tapatalk