Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Stick Sensitivity - Yaw Control

Joined
Jun 7, 2015
Messages
161
Reaction score
80
Age
70
I have had my I2 (Zenmuse X4S) for about 6 weeks, after more than 2 years with my I1. I have a perplexing problem that occurred "suddenly" about a week ago. I was practicing flying early evening at my golf course and noticed the left stick, controlling Yaw with left and right movements (standard Mode 2) had significant lag. Not only was the I2 responding very slowly to yaw inputs but when the stick was re-centered, the craft took a number of seconds to stop yawing.

After much experimenting I have reached the following detailed description of my problem:

With the camera/gimbal set to Free Mode, everything works normally (GPS, Speed, ATTI, Course Lock and Tripod).
With the camera/gimbal set to Follow Mode; ATTI, Course Lock and Tripod work normally but GPS and Speed have the lag problem.
I have done the following: IMU and Compass Calibration, "Restore to Factory Settings" in the DJI Assistant 2 App, deleted and reloaded the DJI Go 4 App on my iPad Air 2, used my iPad Mini as an alternative, and written to DJI Help and quickly received a recommendation to "change" my RC Sensitivity and Gain Setting to those detailed on the 2 images attached.

Nothing has worked.

I am puzzled as to why the Yaw stick sensitivity is only an issue with the camera/gimbal in Follow Mode, and for none of the flight modes with Free Mode selected.

I have yet to do a screen capture of the problem, but it is pretty obvious watching the flight record, with the stick movements displayed. With 100% left and right yaw you can watch the craft slowing turn left and right and continue turning for another few seconds after the stick is centered.

Herewith my settings;

db-settings.jpg db-settings_1.jpg

Any suggestions would be appreciated.

I am also awaiting DJI's response to my lack of success with their first suggestion.

Many thanks

David
 
  • Like
Reactions: uasairsupport
Go to your gimbal settings ( ... -> gimbal -> advanced settings, look for the setting "Gimbal Yaw Smoothness in Follow Mode" and make a note of its value, then set it to zero and try it. Should clear it for you. (Out of interest, Can you post its original value here).

Alternatively, you can simply press reset setting on the same screen to set all values back to default.
 
Last edited:
Nick

Thanks for the tip. It was 52. I have set it to 0 and will test tomorrow. Its 10pm here in Australia. I will post the outcome.

David
 
Nick

Thanks again for your help. Did some flying today all is well. I'm still learning so much about the I2 compared to the I1.

David
 
I'm having the same issue. will give this a try today. But here is my two cents on this. The gimbal setting should not influence the rudder stetting's on the bird. The gimbal should rotate at this set speed to give you the smooth rotation you're looking for but the bird should respond, as it always has, to the stick settings in the MC Setting menu under the Advanced setting screen. This could and will cause a person to run the bird into an object if he is expecting it to rotate like it should. The flight controls should always be separate from the gimbal. I'm thing DJI knows this and we'll see an other firmware update to fix this.
 
  • Like
Reactions: Jonnyb333
Do the new gimbal settings that were advised to you above change your situation? I have the same problem and I'm looking for a fix.
Absolutely. Changing the setting for "Gimbal Yaw Smoothness in Follow Mode" to 0, fixed my problem "permanently. As detailed in posting #2 above, the option is found in Gimbal Settings and then Advanced. Good luck
 
  • Like
Reactions: Hotshots
Doesn't have to be 0, something like 10-20 is probably a reasonable compromise if you want a bit of smoothing at start/end of a yaw in follow mode - 0 gives you an abrupt/hard stop. Have a play with the value and .find something you like, but don't set it too high ;)
 
Same issues. Adjusted those settings and didn't do anything. Sent it in . Was beginning to drop when I was turning. Like you said only in follow mode . In atti mode or camera on free worked fine . Talk to an showed video to a rep he said send it in. Now I wait
 
Did not work for me at all, this does not exist "Gimbal Yaw Smoothness in Follow Mode" , maybe i have new firmware but it just says "Gimbal Yaw Smoothness", the highest value is 30, mine was at 15, even resetting kept it at 15, tried it at 0 and did not work. Sending back to Amazon.
 
'Gimbal Yaw Smoothness' is the wrong setting (there are two similar ones, but which affect behaviour in different modes). You need to find the one that is 'Gimbal Yaw Smoothness in follow mode'. If the value only goes to 30, then you've got the wrong setting.

Dji have recently changed the location of the setting, but it will be there somewhere. The normal place to find it In DJI Go is... Go to main controller (cloverleaf icon)->advanced settings -> sensitivity and check the value for Gimbal Yaw Smoothness in Follow Mode, needs to be below 40-50 to allow the aircraft to yaw. If it's much above that, then the aircraft begins to stop reacting to yaw commands. experiment with a value that suits how smooth you want the camera gimbal to start/stop turning when you turn the aircraft, 0 is abrupt stop without any damping, 100 is 'this lady's not for turning!' 20-30 seems to be a good compromise.

(Iirc, in early firmware & versions of djigo4 the setting might have been under gimbal settings->advanced, certainly for firmware .0330 and djigo4 from 4.1.11 onwards it was moved to main controller-advanced settings) )
 
  • Like
Reactions: Tommy Bayshore
'Gimbal Yaw Smoothness' is the wrong setting (there are two similar ones, but which affect behaviour in different modes). You need to find the one that is 'Gimbal Yaw Smoothness in follow mode'. If the value only goes to 30, then you've got the wrong setting.

Dji have recently changed the location of the setting, but it will be there somewhere. The normal place to find it In DJI Go is... Go to main controller (cloverleaf icon)->advanced settings -> sensitivity and check the value for Gimbal Yaw Smoothness in Follow Mode, needs to be below 40-50 to allow the aircraft to yaw. If it's much above that, then the aircraft begins to stop reacting to yaw commands. experiment with a value that suits how smooth you want the camera gimbal to start/stop turning when you turn the aircraft, 0 is abrupt stop without any damping, 100 is 'this lady's not for turning!' 20-30 seems to be a good compromise.

Thanks for the info NickU, unfortunatly after 10+ hours trying different settings i finally had enough and just shipped it back, i did not feel like it was the hardware but when i took the camera off the gimbal and put the camera back on and it flew perfect for about 5 minutes, then switched to free mode on its on i knew there was some weird problem. I will order another one once they process my refund and keep this info handy in case i run into same issue. Seems as if this may be a common problem and DJI could save themselves alot of returns by educating their technicians, when i spoke to DJI they said no engineer at DJI had ever heard of this issue and the only thing to do would be to send it in for repair, i just bought this a few days ago, thank God i bought from Amazon in this situation because i will probably get a rull refund in just a day or two and i can try again. I will update everyone. This also happened to me after i linked a dual remote operator, before i linked the slave remote there was never a problem...
 
Basically, once the slave rc is coupled up and turned on , the gimbal is always in free mode. When you turn off the slave rc, the gimbal reverts to operating in either free or follow mode depending on the setting. So you'd not be aware of the behaviour when flying with two remotes.

Initially, you may also not have had an issue as the setting may have been at the correct value, but you've either accidentally changed it at some point, or you've updated the dji Go 4 version. Sometimes the Go4 updates will (seemingly randomly) reset some parameter values - one of the recent versions seems to have done this with the gimbal yaw in follow mode value as I've seen an uptick in the number of people encountering this problem in the last month or so.

Dji's own online forum support staff have only just begun to pick up on the setting and how the value affects performance in the last week or two. My guess is they only have a theoretical knowledge of the aircraft rather than an in-depth hands-on knowledge. Sadly, their system developers don't seem to do much in the way of documenting these settings, nor telling their staff what they do!
 

Members online

Forum statistics

Threads
22,329
Messages
210,825
Members
34,888
Latest member
mooseflooring-slc