Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

I'm getting a SD card initializing message on the screen

Joined
Apr 20, 2015
Messages
46
Reaction score
4
Age
59
I'm getting a SD card initializing message on the screen. Everything works and i am able to record video. But annoying message is there with yellow mark. Any ideas
 
Joined
Mar 3, 2015
Messages
51
Reaction score
22
Age
34
Location
Falmouth, Cornwall, UK
Just had this problem (and more) this afternoon, so thought I should share the solution I ended up doing to fix it.

First issue: After the update I had 'card initializing' for one of my cards (standard 16GB card it ships with), and formatting it to FAT32 on either a PC and Mac didn't solve it. Formatting it through the status screen in the app also wouldn't work (kept saying 'format timed out'). I ended up going into the 'settings' menu (top right of App), and formatting the card there. After that it worked.

Second issue: I had a Transcend 32GB card which I've used with the Inspire for months, suddenly after the update it just wouldn't be recognized (App saying: 'card not found'). Tried formatting on PC and Mac, neither worked, nor would formatting it in the App on either the status screen or the settings screen. I was pulling my hair out at this point! Had an idea though, stuck the 'broken' card in a GoPro, let it boot up and then turned it off and took it out. Stuck it in the Inspire and now I got the 'card initializing' error from above. Formatted in settings menu and now it works!

No idea why exactly that would work, but I'm guessing you could stick it in other types of devices with similar effect.

Hope that helps someone else with the same issue :)
 

New Threads

Members online

Forum statistics

Threads
19,708
Messages
192,745
Members
29,083
Latest member
jmi2020