Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Just want to fly... please help


Apr 2, 2015
Reaction score
My brand new Inspire arrived yesterday - 4/1/15. Opened it up, connected to it with the RC and iPhone. Ran through the simulator and everything was fine. Then I saw that there was a firmware update so I downloaded it and got it on the SD card.

Since putting the card into the camera I can no longer connect to the AC with the RC or iPhone app. The AC runs through the update and eventually I get a continuous beep noise and when I look at the TXT file it just says that it failed. I finally tried the update on the RC and that appears to have worked on the first try, but the AC continues to fail. I haven't even been able to attempt to fly this thing. It's been a big letdown. DJI's customer support was worthless and they told me to just send it back. The problem with that is that I need this thing for an upcoming shoot and don't have time to wait for DJI. I also tried exchanging with B&H and of course they're taking the next week off for Easter. If anyone can walk me through how to get my Inspire back up and running, I would really appreciate it.
Did you have any luck yet? Are you making sure the remote is powered off when updating the AC?
Still no luck after countless tries. I've made sure to have the remote off and have reformatted or cleared the SD card each time. Every attempt the AC flashes yellow and does the 4-beep update sound, but then after 10-15 minutes I always end up with the continuous beep.
Before I suggest anything, I want to make sure I understand.

You downloaded it and unzipped onto the SD card for the aircraft first? (did unzip it, right?)

Then it failed, you never got to the remote controller?

I ask because you're suppose to install the update on the aircraft first, then the remote controller.

I had the same issue when I did my update right out of the box. Mine was due to me not removing the folder. Mine would not work until I only had the din file on the card.
Thanks for all the help. I've been sure to unzip the file and have just the bin on the card. I can see the AC updating for at least 10 minutes each time before ultimately failing. DJI says I need to send it in so I guess that's really all I can do at this point.
So you're having problems updating the aircraft, not the remote controller? I ask because there is a special bin file for the remote controller we've been using after you've already updated the aircraft with the stock updated firmware.

The issues have all been with the aircraft. I tried it numerous times and it failed each time after about 10 minutes. Eventually I tried the remote just to see, and that updated just fine. There hasn't been any change in how the aircraft handled things though. Where do you get the special bin file for the remote?
The issues have all been with the aircraft. I tried it numerous times and it failed each time after about 10 minutes. Eventually I tried the remote just to see, and that updated just fine. There hasn't been any change in how the aircraft handled things though. Where do you get the special bin file for the remote?

Before sending it in you should step back and try this all over again from the beginning step by step.

First off:

Are you using the same SD card that came with the camera? IF yes, are you using a Mac or PC. Let me know and we'll go through one step at a time.
I've tried both mac and pc, but use mac the most. I've also tried the original sd card and one of my own.
Ok, if you have access to a PC we can work with just that.

I'm sure you've done all of this already, but it's good to start over from the beginning and do everything in order.

Put the SD card into the PC and right click on the card drive and choose format.
Select the file system as "FAT" (I know some people say FAT32 but do FAT instead)
Leave everything else as it is and select the "Quick Format" option.
Format the SD card.

Once the format is complete, re-download the firmware from DJI website and save it to your computer.
If you are using windows 7 or 8 you should be able to use the built in zip software and right click the downloaded file and select "extract all"
Go through the unzip process and it should now display a new window with the unzipped files (.bin file and a How to update firmware document).
Copy that .bin file (I believe its around 80 MB) to your newly formatted SD card. Ensure you are not copying or creating any folders. Only move the .bin file to the empty SD card.

Once that's complete, eject the SD card from the PC.
Put it into the camera of the inspire.
Make sure your transmitter is TURNED OFF
Power on the aircraft and you should hear the normal initialization sounds.
Then if all goes well, you should hear BEEP-BEEP-BEEP-BEEP over and over again. Give it around a minute to hear the upgrade sounds, it can take some time to start the upgrade process.
If you hear the upgrade beeping, just wait for it to finish and when its done you should hear BEEP-pause-BEEP-BEEP.
The aircraft should turn itself off and back on again.

Power on your transmitter and see if it will now connect to the aircraft.

If it doesn't, go to the Remote settings screen in the pilot app and start a transmitter binding process.
Once the binding process has started, use a pen to press the bind button on the front of the aircraft just inside the nose cone.

Let us know what happens and if you run into issues, where the issue starts and what is happening.
Gave it another shot, still no luck. It began the upgrade sequence with the steady beep, beep, beep, beep - continuing for about 10 minutes, but then it went to the continuous beep after that.

Tried the binding process as well but it never connected and just timed out.

I really appreciate all the help, but at this point it's looking like a bigger problem than I can handle.
I am having this very same issue. Only getting the failure to update error on the card. I have also tried everything listed here on this thread. Originally -= out of the box, the RC connected to the AC with no issues. Both of my RC's are updated and will not connect to the AC and the AC errors out on the firmware update. Is there a way to back into the previous firmware version and then do this all over again?

Note - I posted a new thread and included my log file from the upgrade attempt.
Last edited:

New Posts

Members online

No members online now.

Forum statistics

Latest member