Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

New inspire 2 + X7 no gimbal control

Joined
Jul 23, 2015
Messages
16
Reaction score
6
Age
38
Hi,

I just added another Inspire kit to my gear and I'm having an issue that I have not come across on any of my other Inspires.

Everything is completely normal but I can't pan/tilt/roll the gimbal and there is no gimbal icon display on the app for the master or the slave controller. I have reset all gimbal settings in case there was some kind of false reading in the settings, but no success from that. I also have no control if I tap on the screen and drag the blue circle around. I do have control over the gimbal settings (ISO, shutter, F stop) and the gimbal stabilizes and calibrates totally fine. The connector wires seem to be fine when I look at them and the lack of a gimbal icon on either screen seems to point to a firmware issue. I have tried going between V01.02.0400 and V01.02.0500 and neither of them has solved the issue. I'm unable to downgrade any further.

Here is all the info for the hardware:
Brand new inspire 2 and X7
16mm DJI lens
Standard transmitters for main and secondary with crystal sky 7.85" ultrabright on the mina, Nvidia shield on the secondary controller.
Transmitter firmware are both up to date

Let me know if I left any important info out and I'll add it in.

Thanks for any help.
 
Joined
Sep 13, 2020
Messages
28
Reaction score
11
Age
27
Location
Virginia
Hi,

I just added another Inspire kit to my gear and I'm having an issue that I have not come across on any of my other Inspires.

Everything is completely normal but I can't pan/tilt/roll the gimbal and there is no gimbal icon display on the app for the master or the slave controller. I have reset all gimbal settings in case there was some kind of false reading in the settings, but no success from that. I also have no control if I tap on the screen and drag the blue circle around. I do have control over the gimbal settings (ISO, shutter, F stop) and the gimbal stabilizes and calibrates totally fine. The connector wires seem to be fine when I look at them and the lack of a gimbal icon on either screen seems to point to a firmware issue. I have tried going between V01.02.0400 and V01.02.0500 and neither of them has solved the issue. I'm unable to downgrade any further.

Here is all the info for the hardware:
Brand new inspire 2 and X7
16mm DJI lens
Standard transmitters for main and secondary with crystal sky 7.85" ultrabright on the mina, Nvidia shield on the secondary controller.
Transmitter firmware are both up to date

Let me know if I left any important info out and I'll add it in.

Thanks for any help.
Just to confirm, you've tried the X7 on another I2 and it works fine? If so, I would be suspect of the bird, at which point I would suggest trying to compare the two for any differences.

Other option is if this was purchased brand new from dealer, might still be covered under warranty. Best of luck, mate!
 
Joined
Apr 3, 2021
Messages
23
Reaction score
11
Age
46
Have you tried re pairing the remotes? I bought a cencence and it worked great but the original remote when paired as a secondary remote would only control exposure/shutter etc and not pitch roll pan etc. tried again and again to get it to work and it appeared that a firmware upgrade fixed the pairing issue

good luck with it
 
Joined
Jul 23, 2015
Messages
16
Reaction score
6
Age
38
Reuben, thanks for the reminder to update here.

I got a new X5S to try on it and that worked without issue. I send the X7 to DJI to diagnose the issue and they got it repaired (no indication on what the issue was) and sent back in 5 days. All in all the best DJI repair experience that I’ve had.

Then the next day my crystal sky 7.85” ultra bright had the backlight die in it so hopefully this repair experience goes just as smoothly!
 
Joined
Apr 3, 2021
Messages
23
Reaction score
11
Age
46
Reuben, thanks for the reminder to update here.

I got a new X5S to try on it and that worked without issue. I send the X7 to DJI to diagnose the issue and they got it repaired (no indication on what the issue was) and sent back in 5 days. All in all the best DJI repair experience that I’ve had.

Then the next day my crystal sky 7.85” ultra bright had the backlight die in it so hopefully this repair experience goes just as smoothly!
I hope it’s the end of issues with the I2.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
21,697
Messages
207,237
Members
31,697
Latest member
Pablito46r