Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Phantom 4 Pro (don't shoot me) - battery error and subsequent spaz out

Joined
Jul 24, 2019
Messages
28
Reaction score
10
Age
44
So I posted the below on the PhantomPilots forum and got very little help from those guys - I'm hoping with the leap in expertise on this site (@cruzroy @Donnie Frank @Dobmatt and of course @The Editor), someone might be able to share some advice/wisdom?

My P4P is about 2” from the trash and in need of assistance from you experts out there.

It’s been through the wars a little. When replacing the shell, I stuffed the motors. So I’ve replaced them as well. Got it back to going fine, or so I thought.

Everything shows on screen as perfect - everything in the green - IMU and compass calibration excellent, vision sensors calibrated, firmware up to date, battery at 98% - EVERYTHING is a-ok!

But as soon as I take off I get “Battery signal error”. If I land quick enough, I’m able to land. If I hover too long, it has a spaz-attack and spirals quickly and crashes - it’s almost like one prop goes into reverse, quite weird.

It’s not the battery as I have 5 and they all do the same. I’ve tried resetting the battery - no luck. Pushed in properly? I just cracked one of them making sure it was in properly - it doesn’t go in any further! Airdata gives me no clues, but perhaps my limited experience is the reason for that.

Over almost a year now, I’ve read everything my little brain can cope with and I’m stumped! This is my first and only P4P - I’ve had/have a few Inspires (7), a Spark, 3x Karma’s, a Tello and a Mini - but I don’t know what else to do apart from hand it over to DJI or throw it away (same thing IMO).

Any assistance greatly appreciated before it flies for the last time - thrown off a cliff.
 
Joined
Dec 14, 2017
Messages
324
Reaction score
133
Age
58
So I posted the below on the PhantomPilots forum and got very little help from those guys - I'm hoping with the leap in expertise on this site (@cruzroy @Donnie Frank @Dobmatt and of course @The Editor), someone might be able to share some advice/wisdom?

My P4P is about 2” from the trash and in need of assistance from you experts out there.

It’s been through the wars a little. When replacing the shell, I stuffed the motors. So I’ve replaced them as well. Got it back to going fine, or so I thought.

Everything shows on screen as perfect - everything in the green - IMU and compass calibration excellent, vision sensors calibrated, firmware up to date, battery at 98% - EVERYTHING is a-ok!

But as soon as I take off I get “Battery signal error”. If I land quick enough, I’m able to land. If I hover too long, it has a spaz-attack and spirals quickly and crashes - it’s almost like one prop goes into reverse, quite weird.

It’s not the battery as I have 5 and they all do the same. I’ve tried resetting the battery - no luck. Pushed in properly? I just cracked one of them making sure it was in properly - it doesn’t go in any further! Airdata gives me no clues, but perhaps my limited experience is the reason for that.

Over almost a year now, I’ve read everything my little brain can cope with and I’m stumped! This is my first and only P4P - I’ve had/have a few Inspires (7), a Spark, 3x Karma’s, a Tello and a Mini - but I don’t know what else to do apart from hand it over to DJI or throw it away (same thing IMO).

Any assistance greatly appreciated before it flies for the last time - thrown off a cliff.
first thing i would check if its been taken apart is the antennas, if they did not get pluged in right...the motors caz a electrical magnetic vibration ant will effect its flight, and trust me P4 is like taking and i phone apart...
 
Joined
Mar 20, 2017
Messages
342
Reaction score
112
Location
Arizona
Possibly a pinched wire inside when the shell went back together?
They are a bit of a PIA trying to keep all the wires where they need to be.
Post back as you go please.
 
Joined
Dec 13, 2018
Messages
58
Reaction score
29
Age
71
Location
Hawaii
Website
www.HawaiiAerialVisions.com
Send it to DJI... we have had about 8 causes to send our birds back... they have ALWAYS been fast, efficient and very reasonable ($185 for a completely demolished P4P) you get back a brand new P4P (for all intents and purposes) will always recommend DJI service... have no reason to buy any of their "insurance" programs as they are so reasonable. Good luck... Aloha
 
  • Like
Reactions: mikieh51

Members online

Forum statistics

Threads
21,923
Messages
208,715
Members
32,142
Latest member
uav_pilot_bf