Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Updating batteries

Joined
Mar 14, 2015
Messages
5
Reaction score
0
Age
60
I am having issues with updating 2 of my batteries. I performed the FW update on my I1 and the battery in it at the time without any problem. I have tried updating a TB47 and a TB48 and nothing will happen at all. When i try to fly with either one i get the "battery needs updating". Any suggestions? Thanks
 
Joined
Mar 14, 2014
Messages
247
Reaction score
60
Location
Toronto, ON / Buffalo, NY
Leave the firmware update file in your SD card while you power on with your different batteries, it should run the update each time a new battery is detected.
 
Joined
Mar 14, 2015
Messages
5
Reaction score
0
Age
60
Appreciate the responses, however i have already tried this before i sent in my email and they still will not update. I have flown using both hoping it was a reset issues maybe but still nothing. I think i will try and download the update back onto the sd card maybe and try it again. Just don't want to be flying with these two batteries and in mid flight they shut down or something.
 
Joined
Feb 25, 2015
Messages
7
Reaction score
0
Age
49
Hi Eagle1 ,

I'm having the exact same problem. Did you resolve / update the other batteries ?
 
Joined
Mar 14, 2015
Messages
5
Reaction score
0
Age
60
Hi Eagle1 ,

I'm having the exact same problem. Did you resolve / update the other batteries ?
I never did get them to update, still having the same problem with 2 batteries
 
Joined
Feb 25, 2015
Messages
7
Reaction score
0
Age
49
Ok, managed to get mine updated now. Tried different sd cards with firmware. Formatted one and put firmware on. Don't think that worked. Tried original sd card with firmware and that worked. Took a lot of time though swapping and trying.
 
Joined
Feb 19, 2015
Messages
650
Reaction score
267
Age
51
Location
OKLAHOMA,USA
Still having this problem with my newest TB48. I have also tried to format and re-drop the new FW, this one battery just will not take it. I have ran it down to 30%, recharged, still get the error. I would run in down to 0%, but this battery only has 2 cycles on it.
 

New Threads

Members online

Forum statistics

Threads
19,384
Messages
190,148
Members
28,743
Latest member
Beanyboy