Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Used Inspire 1 Remote issues

Joined
Mar 15, 2024
Messages
4
Reaction score
0
Age
47
For the Inspire 1:

I'm trying to solve connection issues between the remotes (both gl658A) and the app (DJI Go v. 3.1.80)
I have a compatible tablet (Nvidia Sheid) and have tried a Pixel 7 Pro, and a OnePlus 3 and different cables with the same results.
The slave remove's status light shows purple (set up as slave and connected.) The master shows a red status light (remote okay but not connected to aircraft.)
When I restart the Inspire, the master, attempts to connect (quick cycling between red and green) and finally settles on red. Neither shows up in the Go app.
I purchased the Inspire 1 used. Both remotes were preset in their roles when I got them.

Optionally Is there a way to force the slave controller into master mode?

If the main board is bad, would the aircraft still go thru a firmware update and write logs to the sdcard? Could this be a mismatched firmware issue?


I may need to replace the hdmi / usb module in the remotes. Looking around online and the prices are a bit steep. Is there another way to go about fixing this issue?

Logs: WM610_FW_RESULT_AB.txt---Result: Success.========== 2014.01.01 00:00 - Pastebin.com
Images:
 
I can't answer everything here, but the slave can definitely be reset to a master remote. Any Inspire 1 remote can perform either role.
Thank you for your answer, the main issue at this point is the app not connecting with the remote. Only thing I can think of at this point is the usb board.
 
Did you figure this out? I was just looking through and saw this post. In my case with similar issues, it was the $100 USB board on the controller. Easy swap and it worked immediately. The I1v1 I got had sat for may years without being flown and the controller I guess lost it's brain as it only had a couple hours of flight time it's whole life. I'm seeing used remotes for the price of the board these days. Anyway - I know this is old, but I thought I'd throw in my 2 cents. Cheers!
 
  • Like
Reactions: CoreySnipes
Did you figure this out? I was just looking through and saw this post. In my case with similar issues, it was the $100 USB board on the controller. Easy swap and it worked immediately. The I1v1 I got had sat for may years without being flown and the controller I guess lost it's brain as it only had a couple hours of flight time it's whole life. I'm seeing used remotes for the price of the board these days. Anyway - I know this is old, but I thought I'd throw in my 2 cents. Cheers!
I have an Inspire v1.2 and am experiencing the same issue. Would you recommend replacing the remotes over the USB board on the controller?
 
That's a great question. I bought the board for the repair about 3 or 4 years ago and I just bought a second remote for my inspire for $80 (for an assist with camera control). I think if I had a choice now, I would buy a second remote. But that's me. Id go for the cheapest option.
 
I ended up buying new remotes from someone in the Inspire Facebook group. They worked with the drone and I finally got it in the air. Now on to gimbal replacement.
 
Thank you for your answer, the main issue at this point is the app not connecting with the remote. Only thing I can think of at this point is the usb board.
Take the slave controller, rebind to the aircraft, using bind procedures with button on aircraft, then you should be able to change its function to Master Controller in the app.
 

New Posts

Members online

No members online now.

Forum statistics

Threads
22,339
Messages
210,879
Members
35,051
Latest member
Miguelneign