Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

X5R and Manual Lenses with RAW Stills

Joined
Mar 7, 2021
Messages
2
Reaction score
0
Age
45
We have an Insire 1 RAW with the X5R camera. That's all working fine, but we recently purchased a manual (no electronics) lens, specifically, the Laowa 7.5mm (though any no-electronics lens should be equivalent).

The drone & camera are running the latest firmware and the app is up to date.

I am struggling to get the camera to work in RAW mode with still images. This works fine with several electronics-enabled lenses. However, with the Laowa lens attached, the drone will not take pictures at all. Tapping the shutter button does nothing. I can't even switch between video and photo modes on the app - the buttons just hang. I'm trying to use the camera in "M" mode. With the Laowa lens I've even tried the hot-swap technique (though it makes me very nervous to touch the gimbal while it's powered up) from a DJI 15mm lens to no avail.

It seems to work in JPEG mode. I don't care about validity of EXIF data; I can clean that later if I have to, I just want the camera to snap the picture. Is this a limitation (can't ever do RAW) or am I missing something? Has anyone gotten a fully manual lens to take a RAW still on the X5R? Note that I want a full-resolution RAW 16MP still, not the ~8MP RAW that comes from a RAW video. Another weird thing: the SSD doesn't seem to show up when the drone is powered up with the Laowa attached. I have a theory on why this happens (shared SPI bus between the SSD and the lens, but I can't prove that and I can't see why the SSD would have SPI in the first place).

Has anyone tried to glue a focus confirmation chip like the Dandelion onto this lens and if so, did that solve the above problems?

Thanks to any help anyone can be! I'm stumped....
 
Joined
Apr 22, 2016
Messages
494
Reaction score
143
Location
Sofia
Website
goldenskybirds.com
This was mentioned several times in this forum, try to use the search for lawova 7.5mm to get more details.
In short you have to power the drone with the 15mm dji lens. After it boots correctly, press the shutter button to take a photo. Then do a hot swap of the lens and press the shutter button again to take photo with the 7.5mm. It will take a few seconds until it takes the photo, this is only the first one, then it should work. Sometimes you have to press the shutter more than once to get it working.
 
Joined
May 4, 2019
Messages
4
Reaction score
2
Age
67
Laowa has a newer version of the 7.5 lens with auto aperture. (Laowa 7.5mm f/2 MFT - LAOWA Camera Lenses) It is in the correct weight range to work on the X5R. I have tried the hot swap method, and to be honest it's not worth the risk of damaging the X5R gimbal and sending in to DJI for repair. Use the right tools for the job. The regular 7.5 lens also will not shoot raw video without a hot swap. Not a problem on the X5, but useless on the X5R. Sent my 7.5 non auto aperture back....
 
  • Like
Reactions: niki
Joined
Mar 7, 2021
Messages
2
Reaction score
0
Age
45
Ah, thank you both!

I had read the previous posts describing the hot-swap procedure and couldn't figure out what I was doing wrong. I had missed the "take a picture with the 15mm lens" step.

However, I had also missed that there was an auto-aperture version of the lens (we got this one used on eBay). Given how sketchy the hot-swap procedure is coming from a Canon camera, I made the mistake of assuming manual lenses would be no problem on the drone and didn't do enough homework first; now I know) we will likely just resell this version on eBay and get the auto-aperture version.
 
Joined
Apr 22, 2016
Messages
494
Reaction score
143
Location
Sofia
Website
goldenskybirds.com
Never had problems with hot swap of the lens, it's very unlikely to toast the camera that way. But definitely avoiding that step is preferred as it takes time especially if you are in hurry like on film or tv set.
 

New Threads

Members online

Forum statistics

Threads
21,555
Messages
206,339
Members
31,453
Latest member
hgnkk01