Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Compass error will not recalibrate

Joined
Apr 6, 2015
Messages
9
Reaction score
1
My compass will not recalibrate, very frustrating. The I1 flew great last weekend with no problems. Tried to fly it the following Thursday in a different location and got a compass error. Was out in the middle of a field with nothing around me but sky and earth. Tried multiple locations in the field with no success. Brought it home and got the same compass error even though I have calibrated it at home in the past. Have the latest firmware on the I1, controller and iPad. Tried different batteries and still got the error. Have tried calibrating it doing the dance and just rotating the I1. Both failed to calibrate the compass. Anyone have any ideas?
 
Joined
Apr 6, 2015
Messages
9
Reaction score
1
Contacted DJI. They said send it to them for repair. Now just need to wait.
 
Joined
Apr 6, 2015
Messages
9
Reaction score
1
Latest versions of the software on the iPad v1.2.0, controller and aircraft are both v1.2.1.06.
 
Joined
Apr 6, 2015
Messages
9
Reaction score
1
Am about a month late in writing this but wanted to give you all an update on my compass issue and my experience with DJI in LA. Overall it was a positive experience, frustrating at times, but positive. Yes there was a long wait, eight weeks, to get the bird back but that was not a problem because August and September are a very busy time of year for us.

When I contacted DJI they gave me an RMA number, after a few email exchanges, and said to send it down to them, which I did the end of July. They wanted the case, bird, camera, and controller. Nothing else. The hard part was finding the cardboard box to pack it in.

As expected eight weeks later I got a few of emails. One with a tracking number for FedEx and another telling me it was on the way. A third email said that instead of repairing my bird they were send me a new Inspire 1, new controller, camera, and new case. When I setup the system it seems to have started a new one year warranty.
 
  • Like
Reactions: Sunscreen

New Threads

Forum statistics

Threads
19,736
Messages
192,946
Members
29,104
Latest member
Xrious