Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Compass Will not Calibrate, ideas?

Joined
Mar 23, 2015
Messages
90
Reaction score
10
Age
35
Tried preforming a compass calibration a number of times. Never Crashed, in the sensors menu is shows -617, -135, 759, 1147. as the numbers.

Any ideas on how to reset, calibrate, etc. I have been flying it for months now and never had issues calibrating before, so yes i know how to do it.
 
Joined
Mar 23, 2015
Messages
90
Reaction score
10
Age
35
Can I degauss the compass on this unit somehow? where is it located in the craft to try that.
 
Joined
Mar 23, 2015
Messages
90
Reaction score
10
Age
35
I have done advanced imu. The uav acts like its drunk it kind of styarts to "fall over" in the sky and I have to compensate for it. its sort of like glying in full manual mode back in the day before atti mode.
 
Joined
Feb 3, 2015
Messages
1,882
Reaction score
733
Does it actually give you a calibration error or not? Nowhere in your posts do you mention if you get a "cannot calibrate" error of if you just "assume" it does not calibrate correctly based on bad behavior in flight.
 
Joined
Mar 23, 2015
Messages
90
Reaction score
10
Age
35
I was wondering if the calibrations numbers are the issue, I assume its the compass, It could be something else, the flight characteristics mirrored what I have experienced before with a bad calibration on a compass. What else could be the culprit for the odd flight?

edit: no calibration error shown on the app.
 
Joined
Feb 3, 2015
Messages
1,882
Reaction score
733
I'd suggest an IMU calibration (perfectly flat and stable surface), then compass calibration (on location).
If that doesn't help try a different location several km away (recalibrate compass), if still no better it's time to contact DJI support.
 

New Threads

Members online

Forum statistics

Threads
19,386
Messages
190,171
Members
28,747
Latest member
nailbiter