Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

connection established but Gimbal disconnected

Discussion in 'Inspire 1 Help' started by roclimber69, Aug 13, 2016.

  1. roclimber69

    Dec 13, 2015
    Likes Received:
    I took the aircraft planning to fly yesterday but ran into trouble. The Aircraft is definitely connected to the controller (tried both iPad2 and Android phone) but with no success. When firing up the aircraft, it has a Blue LED and the camrera only beep once and turned 1/4 way rather than a full circle then stopped.

    here's the troubleshooting steps taken :
    - downgrade firmware to as well as 1.6.0, no connection to aircraft at all
    - upgraded to latest RC firmware, able to communicate , since battery info, aircraft temperature can be seen but "no image transmisison signal", no aircraft firmware.
    - reformat SD card and loaded with , but aircraft still didn't do anything other then blue LED and 1/4 turn of camera , then stuck there.
    - tried adjusting the landing gear to up and down still no avail.

    Called DJI but already went through all the procedures they mentioned.

    any other thing i can try before i take it to the shop?