Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Inspire 1 Jerky Flight with Hangar Autopilot

Joined
Dec 5, 2019
Messages
15
Reaction score
5
Age
49
when I use waypoint mode with Hangar Autopilot, it does this jerky flight thing, as if it were struggling to wrestle control from something else. I've restarted all systems, created new waypoint missions, made 100% sure that DJI software isn't running in the background.
See the symptoms here

Inspire 1 Pro - firmware 1.11.01.50+
RC vers. 1.7.80

I read in Hangar's support section:

Why does the aircraft make abrupt course corrections for some flight paths in Waypoint Mode?
There is an issue in the DJI firmware which can cause the aircraft to pitch/roll more aggressively than necessary to adjust course in some cases. DJI is currently investigating the issue but has not indicated a timeline for releasing a correction. In the meantime, consider using a higher value for the Responsiveness Movement Parameter (for example, 10 seconds). This will smooth out the flight behavior, but it will also cause the aircraft to react slower to very sharp/fast turns. Read More

I tried several settings from 2 seconds to 10... still seems to lurch at most waypoints... just more slowly... but still completely unusable.
Anyone had luck with Autopilot and Inspire 1?
Thanks
Russell
 
Joined
Jun 28, 2016
Messages
1,202
Reaction score
494
Age
56
when I use waypoint mode with Hangar Autopilot, it does this jerky flight thing, as if it were struggling to wrestle control from something else. I've restarted all systems, created new waypoint missions, made 100% sure that DJI software isn't running in the background.
See the symptoms here

Inspire 1 Pro - firmware 1.11.01.50+
RC vers. 1.7.80

I read in Hangar's support section:

Why does the aircraft make abrupt course corrections for some flight paths in Waypoint Mode?
There is an issue in the DJI firmware which can cause the aircraft to pitch/roll more aggressively than necessary to adjust course in some cases. DJI is currently investigating the issue but has not indicated a timeline for releasing a correction. In the meantime, consider using a higher value for the Responsiveness Movement Parameter (for example, 10 seconds). This will smooth out the flight behavior, but it will also cause the aircraft to react slower to very sharp/fast turns. Read More

I tried several settings from 2 seconds to 10... still seems to lurch at most waypoints... just more slowly... but still completely unusable.
Anyone had luck with Autopilot and Inspire 1?
Thanks
Russell
I experience this behavior when reception is poor or there is a lot of WiFi interference. I have one client downtown in a WiFi-saturated environment. The only channel that is truly clear of interference is channel 1. So at this job site I can almost initiate the jerky action at will by using any channel other than channel 1. Too much jerkiness (interference) will almost assuredly eventually disconnect the drone and/or crash the app. So whenever I see this behavior on a job site, I know that I forgot to select a clear channel, which can only be done in the Go App.

This screen shot was taken while at my house. You can see channels 3 and 10 have a lot of interference. When I go to my job site today, all channels will be red except channel 1.

1582559563607.png

Worth noting; Autopilot shows the reception strength on the left side. Keep an eye on that.

1582559910746.png

Here at my girlfriend's house, with the bird a mere foot from the RC, you can see was getting only 96% connection strength. This is probably due to the Xfi router in my girlfriend's home. So keep a sharp eye on that number.

My downtown job nets a max distance of about 400'. Even that close, WiFi interference will screw with the Autopilot / Inspire reliability.

Good luck.

D
 
Last edited:
Joined
Feb 13, 2016
Messages
157
Reaction score
31
Age
71
Location
Montreal
Website
www.photoimagerie.com
I have used Autopilot with I1P a lot since 2015 (but not in the past few months) & not seen that problem. I assume it wasn’t very windy or gusty, it looks a bit like a natural frequency oscillation? Tried changing the speed setting + or - 5 mph in AP? Did it do the same think when you flew manually? Biggest problems I’ve experienced with AP are with iOS updates
 
Joined
Dec 5, 2019
Messages
15
Reaction score
5
Age
49
only time it's ever done that kind of thing is in autopilot. Different speed settings don't have an effect. Also it happens in orbit mode, not just in waypoint mode. But it doesn't happen in DJI orbit mode. Only in autopilot orbit mode or waypoint mode. Someone suggested that it might be a frequency interference issue, but I just got an inspire two, so I haven't gotten back out to test this. My inspired two came with a crystal sky monitor, so I'm not using autopilot anyway at the moment. But maybe I'll connect up the iPad and give it a try today. I will report back
 
Joined
Jun 28, 2016
Messages
1,202
Reaction score
494
Age
56
only time it's ever done that kind of thing is in autopilot. Different speed settings don't have an effect. Also it happens in orbit mode, not just in waypoint mode. But it doesn't happen in DJI orbit mode. Only in autopilot orbit mode or waypoint mode. Someone suggested that it might be a frequency interference issue, but I just got an inspire two, so I haven't gotten back out to test this. My inspired two came with a crystal sky monitor, so I'm not using autopilot anyway at the moment. But maybe I'll connect up the iPad and give it a try today. I will report back
Capture your HD screen pre-flight and post it here. Dollars to doughnuts the channel you are using has WiFi issues. FWIW, I NEVER use "Auto" mode, as the channel switching can cause glitching. I always test the environment via the HD menu, find a free frequency and use that one frequency for the entire shoot. I have mental notes of which channels work at which job. Downtown I have to use channel 1. However, at my Santa Fe shoot I have to use channel 6.

D
 
Joined
Aug 30, 2019
Messages
64
Reaction score
27
I experience this behavior when reception is poor or there is a lot of WiFi interference. I have one client downtown in a WiFi-saturated environment. The only channel that is truly clear of interference is channel 1. So at this job site I can almost initiate the jerky action at will by using any channel other than channel 1. Too much jerkiness (interference) will almost assuredly eventually disconnect the drone and/or crash the app. So whenever I see this behavior on a job site, I know that I forgot to select a clear channel, which can only be done in the Go App.

This screen shot was taken while at my house. You can see channels 3 and 10 have a lot of interference. When I go to my job site today, all channels will be red except channel 1.

View attachment 28146

Worth noting; Autopilot shows the reception strength on the left side. Keep an eye on that.

View attachment 28147

Here at my girlfriend's house, with the bird a mere foot from the RC, you can see was getting only 96% connection strength. This is probably due to the Xfi router in my girlfriend's home. So keep a sharp eye on that number.

My downtown job nets a max distance of about 400'. Even that close, WiFi interference will screw with the Autopilot / Inspire reliability.

Good luck.

D
Thanks good info I forget to check that often
 

New Threads

Members online

Forum statistics

Threads
20,165
Messages
196,104
Members
29,618
Latest member
lol090