Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Inspire 1 won't connect

Joined
Jan 17, 2019
Messages
166
Reaction score
32
Age
78
I can't even remember what the manual says with regards to which should be on first, controller or craft. Seems it works either way for me, even with the Crystal Sky which has both Go and Go 4. Try powering down everything, then power on I1, wait, then controller. If that doesn't work, power down again, re-try with controler 1st, then drone. Likely you have tried all of that and apologize if so.
 
Joined
May 20, 2019
Messages
19
Reaction score
1
Age
48
I've tried to reconnect both ways ,tried to reset controller, updated the firmware in the Inspire but won't update on the controller even tried to reconnect with the red button on the bird still nothing...
 
Joined
Jan 17, 2019
Messages
166
Reaction score
32
Age
78
H
I've tried to reconnect both ways ,tried to reset controller, updated the firmware in the Inspire but won't update on the controller even tried to reconnect with the red button on the bird still nothing...
Has it ever connected as I didn’t see history of you, controller, etc. Have you ever flown this unit with existing gear. Where are you located?
 
Joined
May 20, 2019
Messages
19
Reaction score
1
Age
48
Yes it worked fine just turned it on one day and it didn't work ,I'm located in Berwick upon tweed
 
Joined
Jan 17, 2019
Messages
166
Reaction score
32
Age
78
Yes it worked fine just turned it on one day and it didn't work ,I'm located in Berwick upon tweed
I would’ve lent you my spare controller if in states but presume Berwick etc in UK. I’m at a loss other than something dumb and simple like reseating the X3/Zoom/X5 and starting all over?
 
Joined
Jun 28, 2016
Messages
757
Reaction score
271
Age
56
Okay....so clearly the iPad is NOT connecting with the controller. This is NOT a firmware or software issue. The Go App doesn't care which version of firmware you are running. The Inspire 1 controller only has two firmware versions; 1.6 and 1.7. And any version of the Go App will connect to those versions. So clearly this is a hardware issue. If I recall, you already tried different cables, plugging and unplugging, reorienting the connection at the iPad, RESETTING THE CONTROLLER, etc. I can conclude here with a very high level of confidence that your USB port is shot. This is NOT something "simple."

If this were my bird, I would make an effort to clean the USB pins with alcohol, Q-Tips, and possibly scrape the metal pins with a tiny screwdriver. Barring that, the USB unit is modular and can be replaced. If I couldn't get the USB port working, I would consider replacing the USB module. If the module is too expensive and/or complicated for your liking, then go back to eBay. This time make sure the seller tests the USB port and is willing to offer a 100% warranty against a bad port. If you get that in writing in email, eBay will force the seller to stay true to his/her word.

Consider this problem solved.

Good luck.

D
 
Last edited:
Joined
Jan 17, 2019
Messages
166
Reaction score
32
Age
78
I wish I were that confident problem solved, tho’ Occam might agree with you lol ie Occam of Occam’s razor who is misquoted often!
 
Joined
Jun 28, 2016
Messages
757
Reaction score
271
Age
56
I wish I were that confident problem solved, tho’ Occam might agree with you lol ie Occam of Occam’s razor who is misquoted often!
Based on all the data I have been given and the exchange of comments, I can say with 100% confidence that I have troubleshot this problem. The only way I'm wrong is if any of the input data is incorrect.

D
 
Joined
May 20, 2019
Messages
19
Reaction score
1
Age
48
Second hand controller connected and everything works fine happy days so I must be a faulty module on the other one thanks for your help .😁
 
  • Like
Reactions: Mixchief

New Threads

Members online

Forum statistics

Threads
19,249
Messages
189,204
Members
28,510
Latest member
HueyAddis