Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Inspire 2 - Video Transmission - Use 2.4 or 5 GHz?

Joined
Apr 19, 2015
Messages
78
Reaction score
10
Location
Rocklin, CA
Experiencing losses in X5S video transmission from Inspire 2. Are the frequencies on which each of the video and control signals travel, 2.4GHz & 5 GHz, swappable? What is the default and what is the recommended frequency for each Video and Control transmission? Firmware versions: Aircraft = 4.3.46; Remote Controller = 1.02.0600; Ram Controller = 01.41.01.72; X5S Camera = 01.11.22.29. What are other tried and true techniques to boost video transmission strength? Thank you.
 
Joined
Nov 17, 2017
Messages
742
Reaction score
300
Location
Australia & Europe
Experiencing losses in X5S video transmission from Inspire 2. Are the frequencies on which each of the video and control signals travel, 2.4GHz & 5 GHz, swappable? What is the default and what is the recommended frequency for each Video and Control transmission? Firmware versions: Aircraft = 4.3.46; Remote Controller = 1.02.0600; Ram Controller = 01.41.01.72; X5S Camera = 01.11.22.29. What are other tried and true techniques to boost video transmission strength? Thank you.
Again, what do you exactly mean by loosing video transmission? If you are using the CrystalSky display it tends to crash, well actually the GO4 tends to crash causing the video feed to freeze on the display. Some people are saying that I-pad mini or one of the recent Samsung tablets are more stable platforms than CrystalSky. What display do you use?
 
  • Like
Reactions: Donnie Frank
Joined
Apr 19, 2015
Messages
78
Reaction score
10
Location
Rocklin, CA
Again, what do you exactly mean by loosing video transmission? If you are using the CrystalSky display it tends to crash, well actually the GO4 tends to crash causing the video feed to freeze on the display. Some people are saying that I-pad mini or one of the recent Samsung tablets are more stable platforms than CrystalSky. What display do you use?
The video feed pixelates then turns green on the Applie iPad. Weak video signal notification also appears.
 
Joined
Nov 17, 2017
Messages
742
Reaction score
300
Location
Australia & Europe
There could be many reasons for this.
I'd start with cleaning the strip contacts on the camera mounting plate and on the gimbal.
If that does not help, I'd have a look at the antennas in legs of the I2 and unplug, clean and replug the tiny gold connectors there. If that does not help, I'd check my controller if the antenna wires are firmly attached to the antenna ports from inside. They can brake-off over time( it happened on my Cendence) from the strain on the wires caused by frequent turning the antennas on the controller from transport to rabbit ear possition. If that does not help you might need to send the whole thing in for service.
 
  • Like
Reactions: hhung516 and John
Joined
Apr 19, 2015
Messages
78
Reaction score
10
Location
Rocklin, CA
There could be many reasons for this.
I'd start with cleaning the strip contacts on the camera mounting plate and on the gimbal.
If that does not help, I'd have a look at the antennas in legs of the I2 and unplug, clean and replug the tiny gold connectors there. If that does not help, I'd check my controller if the antenna wires are firmly attached to the antenna ports from inside. They can brake-off over time( it happened on my Cendence) from the strain on the wires caused by frequent turning the antennas on the controller from transport to rabbit ear possition. If that does not help you might need to send the whole thing in for service.
Good suggestions. Thank you.
 

New Threads

Members online

Forum statistics

Threads
21,734
Messages
207,524
Members
31,777
Latest member
Agustinboody