Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Loss of video with Android 4.4.2 on Hudl 2 after minimising Pilot App

May 14, 2015
Reaction score
East Sussex, UK
Up to now I've been using my iPad Air but yesterday I tried a Hudl 2 (UK tablet from Tesco) running Android 4.4.2 with the possibility of using it as a dedicated screen for the Inspire. The size is ideal (fits exactly into the manual slot in the case) and at £99 or less it's very affordable, and it gets good reviews as a tablet. While not up to the iPad standard it seems to work well enough though the video image is a little jerky and I don't like the Android features / settings as much (though I expect the next release will be an improvement). I shut down just about everything I could to make sure the maximum processing power was available to run Pilot App.

However one BIG problem I discovered is that if I come out of the Pilot App (without shutting it down) to look at the home screen or another app, then when I go back to Pilot App the video signal has gone for both live feed and playback and the 'No Signal' message is displayed, but the aircraft controls still operate okay. Whatever I try I can't get the video back without powering down the aircraft and RC and doing another start-up. I've uninstalled and reinstalled Pilot App and have the latest firmware and software installed and the Android USB connection set to PTP.

I've had a good look on the forum to see if anybody else has the reported this issue but can't find anything qite like this. I know the Hudl is cheap and not a Dji supported device but before blaming the hardware I'd like to know if anybody else has (had) this problem and if so is there a solution within the Android settings - or is it just a known bug in the app?

Any helpful ideas ?
You might need to fully close the app and open it again, either by switching to it and pressing the back button until it's closed, or my showing recent apps and closing it.

If the tablet has insufficient memory just going to the home screen might improperly kill some parts of the DJI app to make room to load the home screen again.
Even on top of line devices when exiting the DJI app the homescreen is reloaded, while most other apps don't need enough resources for it to close itself.
Thanks for the tip but I've tried that. It seems that once I've lost the video the only way to get the link back is by restarting the aircraft.

New Posts

Members online

Forum statistics

Latest member