Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Problems attaching gimbal

Joined
Nov 14, 2015
Messages
285
Reaction score
65
Age
66
Location
Baltimore MD
Website
www.adelbergphotography.com
I've had issues attempting to attach the x5 gimbal on two different kits. The locking collar will not turn to the lock position.

The only way I can attach it is to loosen the 4 set screws on the gimbal itself , mount and engage collar and then tighten the set screws! Naturally I then cannot rotate the collar to remove the gimbal without reversing the procedure.

Any one had this experience? remedy?
 
There is a screw on the locking collar. Just unscrew it a bit to loosen the lock.
 
Yes the collar rotated just fine to remove the plastic cap that was there. It rotates fine with nothing there. But will only rotate about 1/4 inch with gimbal in place or as I see it until the beveled edge begins to turn flat. Just won't come up over that spot from the bevel on the front where I can see. It might be the same for the back two? It's seems the tolerances are off someplace? Might be the two aligning pins don't fit into the two holes on each side keeping the gimbal from going all the way down?

Once it's on, collar rotated and 4 screws tightened the collar won't turn but the camera and gimbal test out fine and upgrade completed.

Wish I didn't have to use that upgraded firmware but it came with 1.9 and my old ac had 1.0.2 from 11/15. The ac would not take that sd card or downgrade [emoji83]
So I'm left with poor signal strength from repeater![emoji83]
 
Humm. All I can add to it is to make sure the back grove of the gimbal is attached on the aircraft slot (photo1,2) And make sure you push upwards where the connection happen then rotate the lock. (Photo 3)
844f82d33f5686e8d4e4cbd98157c0c8.jpg
1e0e43633be7a9aae48409dbc657e20a.jpg
5732e33d107228c7e70f374f0ea0f8b7.jpg
 
Just bought a used inspire 1v2 with x3 and x5. Only ever had phantoms so this was a learning experience and above posts and another had these fixes that worked for me: 2 things fixed it immediately. First, clean the lock slide / groove / tabs on camera and mount with a q-tip and then a q-tip over the same areas with a hint of some kind of lube (I used a touch of coconut oil). After cleaned/lubed, ensure the slot and tab are fitted at the rear of the docking area first, then angle/tilt it level toward the white lubber lines until it fits flat. It should now turn freely. Woohoo!
 
Had an issue where somehow the plate did not rotate back into position after removing the camera before packing the drone up. Was trying to get the gimbal inserted and locked in for a while with no success. Came back to it later and realized that if you hold the release button down, you can manually rotate the connector plate back into position. Problem solved.
 
Had an issue where somehow the plate did not rotate back into position after removing the camera before packing the drone up. Was trying to get the gimbal inserted and locked in for a while with no success. Came back to it later and realized that if you hold the release button down, you can manually rotate the connector plate back into position. Problem solved.
YES!!!!! It took me a few days of back & forth with DJI who had just repaired crash damage and installed a new gimbal carrier among many other parts 😳. They gave me a link to this dialogue - 2 minute fix!!
 

New Posts

Members online

No members online now.

Forum statistics

Threads
22,334
Messages
210,842
Members
34,935
Latest member
liamjames