Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Replacement left arm - antenna connectors different than original

Joined
Oct 11, 2021
Messages
2
Reaction score
0
Age
46
I recently bought a replacement left arm for my Inspire 2. I needed to replace the antenna cable that runs to the leg as it was damaged when a landing gear leg broke. I couldn't find just the cable, so I had to order a whole new leg. Anyway, I started to replace it this past weekend and noticed that the connectors that attach to the antennas in the legs were different than the stock connectors. It looks like they're the wrong gender. I've attached photos showing the two original connectors and the replacement connectors. I originally questioned if I was sent a right side arm by mistake, but it's definitely the correct arm. Has anybody else seen this or have any suggestions? Is it possible it was produced with the wrong connectors? I'm baffled and any help would be appreciated.

Original left front
Original - left front.jpg
Original left rear
Original - left rear.jpg
Replacement left front
Replacement - left front.jpg
Replacement left rear
Replacement - left rear.jpg
 

AAP

Joined
Sep 13, 2020
Messages
4
Reaction score
0
Age
48
I recently bought a replacement left arm for my Inspire 2. I needed to replace the antenna cable that runs to the leg as it was damaged when a landing gear leg broke. I couldn't find just the cable, so I had to order a whole new leg. Anyway, I started to replace it this past weekend and noticed that the connectors that attach to the antennas in the legs were different than the stock connectors. It looks like they're the wrong gender. I've attached photos showing the two original connectors and the replacement connectors. I originally questioned if I was sent a right side arm by mistake, but it's definitely the correct arm. Has anybody else seen this or have any suggestions? Is it possible it was produced with the wrong connectors? I'm baffled and any help would be appreciated.

Original left front
View attachment 31495
Original left rear
View attachment 31497
Replacement left front
View attachment 31494
Replacement left rear
View attachment 31496
That’s odd. Is your I2 new or did you buy used? The replacements look like original and oem. Your original connections look very odd and not correct.
 
Joined
Apr 3, 2021
Messages
15
Reaction score
2
Age
52
I recently bought a replacement left arm for my Inspire 2. I needed to replace the antenna cable that runs to the leg as it was damaged when a landing gear leg broke. I couldn't find just the cable, so I had to order a whole new leg. Anyway, I started to replace it this past weekend and noticed that the connectors that attach to the antennas in the legs were different than the stock connectors. It looks like they're the wrong gender. I've attached photos showing the two original connectors and the replacement connectors. I originally questioned if I was sent a right side arm by mistake, but it's definitely the correct arm. Has anybody else seen this or have any suggestions? Is it possible it was produced with the wrong connectors? I'm baffled and any help would be appreciated.

Original left front
View attachment 31495
Original left rear
View attachment 31497
Replacement left front
View attachment 31494
Replacement left rear
View attachment 31496
Hello ..! .. It is very strange that the connectors of the replacement arm do not coincide with the connectors of the original antennas of your Inspire, I suggest you contact the supplier where you bought the replacement and ask him about the antenna connectors perhaps They were badly assembled which would mean making a change in the existing connectors on the arm or changing the existing connectors on the antennas to match the connections. I hope you can find a prompt and favorable solution to your problem ... good luck!
 
Joined
Oct 11, 2021
Messages
2
Reaction score
0
Age
46
Hello ..! .. It is very strange that the connectors of the replacement arm do not coincide with the connectors of the original antennas of your Inspire, I suggest you contact the supplier where you bought the replacement and ask him about the antenna connectors perhaps They were badly assembled which would mean making a change in the existing connectors on the arm or changing the existing connectors on the antennas to match the connections. I hope you can find a prompt and favorable solution to your problem ... good luck!
Thank you everybody for your replies. Turns out that when I removed the antennas, a part of the connector from the leg came off and was stuck in the antenna. I contacted the supplier and sent the same photos and they replied letting me know this. I was able to remove the broken pieces from the antennas and they mated up to the new arm without a problem.
 

New Threads

Members online

Forum statistics

Threads
21,418
Messages
205,474
Members
31,195
Latest member
AaliyahSerenity