Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Which firmware update for Inspire 1V2.0

Discussion in 'Inspire 1 Discussion' started by C.Harris, Jan 2, 2016.

  1. C.Harris

    Dec 28, 2015
    Likes Received:
    I bought a Inspire 1 V2.0 a few days ago,while I was there the aircraft got updated, and the camera I think. I got there are the end of the day and they did not update my batteries, figured I'd do it at home. I am a phantom 3 owners as well and am familiar with updates.

    Here is the versions i have :
    I am using a Ipad mini 2

    App 2.4.3
    Rc 1.5.70

    The aircraft ver is what is puzzling, it says +. But the latest firmware of 2015-12-22 says ver I'm assuming the update in the office worked.

    On Dji"s website they have listed :
    Inspire 1 Firmware v.

    Inspire 1 Firmware v.

    Inspire 1 Firmware v1.4.0.10
    Inspire 1 Firmware v1.3.0.00

    How to Update Firmware v1.4

    The first one listed as of 12/22 says a different number than what mine is, which one of these should I choose to update the batteries?

    Also, speaking of batteries. I am a Phantom 3 pro owner as well, it is recommend to break the batteries in flying the first 10 flights not below 50%. Does the same apply for the Inpsire 1V2 batteries?

    Thanks in advance,

  2. Groover49

    Nov 30, 2015
    Likes Received:
    I just updated my Inspire 1 V2.0 last night to the v1.6.0.40. I assume it will be fine as I haven't flown since the update. I don't believe there was much difference from v1.5, it was something to do with cold batteries. This is not a problem I will face in Australia. Not at the moment anyway. The funny thing is, I thought I'd updated to v1.5 a month ago and I too was surprised to see v1.4 when I looked. Don't know????
    The firmware update is an all in one as far as I'm aware. The Aircraft will update everything all at once. When you plug an old version battery into the updated craft I'm pretty sure they get updated then? My bad. You must have the .bin file on the supplied Micro SD with each battery that is plugged in and needs to be updated. The Aircraft will know it is already updated and the battery firmware is the only thing that will change.
    It would have been nice if the update went smooth but I was literally going out of my mind for an hour last night. No matter what I did the Aircraft would not accept the update! Finally I remembered something about using the supplied Micro SD and Ta Da it worked.
    What is so special about the original supplied Micro SD?
    Is it to do with formatting with the Aircraft?
    I just find this rather strange and of course concerned if I lose the original Micro SD!!
    Also, I have not heard of breaking batteries in. Admittedly, all of my flights probably haven't taken the batteries much past 50% anyway.
    All the best
    #2 Groover49, Jan 2, 2016
    Last edited: Jan 2, 2016