Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Can't update RC FW from 01.01.0060 to 01.01.0080

Joined
Nov 22, 2019
Messages
32
Reaction score
7
Age
38
Hi guys,
Did a quick search before posting, didn't find anything so hopefully it's not a repost.

I just updated Inspire 2 aircraft FW to 01.02.0500 last night. Afterwards I tried multiple times to update the remote controller (stock, not Cendence) FW but wasn't successful.
Before the update the AC was on 0300 and RC is on 01.01.0060. I believe RC FW 01.01.0080 is the one DJI released along with the AC FW 0500.

Anyone having the same issue?
And more importantly, has anyone been flying 01.02.0500 AC with 01.01.0060 RC? Any issues at all?

Here's what I tried:
- On two different iPhones launched Go4 (one Go4 is the latest) and saw "checking FW" msg and it says it's on the latest and msg just disappears after.
- In Go4 held on the menu button for 5 seconds to bring up the "secret" page, it says Get Firmware Version Failed, so couldn't do it there either.
- Connected the RC using a micro USB cable to PC running Assistant 2 (the one I used to successfully update AC FW), it detected the device (as something like COM4), but nothing happened in Assistant 2. I think Assistant 2 isn't designed to update the RC FW at least for this model, right?

Would really appreciate some insights on this matter.

Ps: I've waited a long time before updating to 0500 to make sure there are no issues. Seems like a pretty stable version except I did come across a couple guys complaining about the power throttling when doing extreme maneuvers. Anyway after the update it seems to get the heading drift issue under control. Haven't done any flying yet.
 

New Threads

Members online

Forum statistics

Threads
21,318
Messages
204,827
Members
31,019
Latest member
Donatas