Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

General firmware questions

Joined
Oct 18, 2022
Messages
2
Reaction score
0
Age
29
I have an Inspire V1 that looks like it's never been flown, not a scratch nor scuff to be seen. I am dying to fly it but am having a little trouble with the firmware side of things.

I don't want to update to the newest FW just yet, just get it running on the bare minimum (since it's currently stuck in travel mode). With that in mind:

  1. How do you check the current firmware? Is it the "Version" (1.02.00.12) in the DJI Go app? If so where can I find a copy of 1.02.00.12?
  2. I know that the battery FW is intergrated into the craft FW package, does this hold true for the remote or is that separate?
  3. If #2 is the former, do the versions have to be EXACTLY the same? Closest I can find by using this is 1.02.00.13.
  4. If #2 is the latter, is there a repo of the remote firmware? All I can find is 1.03.0.
  5. Is there FW rollback prevention to be aware of and if so which is the latest I can go without it?
App: 3.1.74, Version: 1.2.0.12, Remote: 1.7.80 (This is the only version I've tried that doesn't show the "update firmware" message).

Thanks, if I need to include any more info please let me know
 
Last edited:
Joined
Jun 28, 2016
Messages
2,064
Reaction score
889
Age
59
This subject has been covered many times. Do a forum search for "firmware" and read any one of the dozens of articles to have all your questions answered, including questions you haven't even thought to ask yet. Don't even power up your Inspire until you've read at least a couple threads on the subject.

D
 
Joined
Oct 18, 2022
Messages
2
Reaction score
0
Age
29
This subject has been covered many times. Do a forum search for "firmware" and read any one of the dozens of articles to have all your questions answered, including questions you haven't even thought to ask yet. Don't even power up your Inspire until you've read at least a couple threads on the subject.

D
I've read a whole ton over the past day, enough that I felt confident to proceed:

Started off by trying to downgrade the RC, after that and a couple of pairings to the craft I was able to see that it was actually on 01.04.00.10 instead of 01.02.00.12. The camera FW was update to the latest, so I decided to just update to 1.11.01.50.

Firgured out pretty quickly that the gear on the landing gear servo is spinning freely, had to take it out of travel mode in the app and manually turn the screw shaft.

After various attempt to update the FW that failed due to a typo in the .bin filename (generated by the link I put in OP), I finally got the bzz-bzz-bzz-bzz noise when I turned the craft on (Following your nice guide on the DJI forums, thank you for that).

Unfortunatly about 30 minutes into it, the buzzing stopped and the gimbal went limp. I left it running for roughly an hour before turning it off. Shortly before this happened the craft made the "booting up" noise a couple of times, not sure if that's abnormal though as some of the videos I watched said that it could do random things.

The log file showed that it was updating, then on the last section it had about 8-10 lines about a device being detected. (I stupidly deleted the file thinking I had backed it up. All I can say is that it WASN'T next to 0800 & 1500 as you indicate in your log file thread).

Past that, the craft reports that it's on 1.11.01.50+. Haven't tried controlling it at all, having a break for the rest of the night.

Sadly the camera (X3), no longer moves or shows footage. The fan still spins so there's that, but even in my Osmo it's limp. It's brand new so I assume the firmware bricked it somehow. The Osmo camera shows a feed on the craft so I think it's all good that side.

Any ideas please shoot them my way. I'll keep digging around for more info

Edit: Couldn't resist. Can confirm that the craft and RC are both fully updated and it has flight capability. That just leaves the servo (can fix), and the camera (ugh, please be able to fix. Got a good deal on it and the rest aren't cheap).
 
Last edited:
Joined
Jun 28, 2016
Messages
2,064
Reaction score
889
Age
59
I've read a whole ton over the past day, enough that I felt confident to proceed:

Started off by trying to downgrade the RC, after that and a couple of pairings to the craft I was able to see that it was actually on 01.04.00.10 instead of 01.02.00.12. The camera FW was update to the latest, so I decided to just update to 1.11.01.50.

Firgured out pretty quickly that the gear on the landing gear servo is spinning freely, had to take it out of travel mode in the app and manually turn the screw shaft.

After various attempt to update the FW that failed due to a typo in the .bin filename (generated by the link I put in OP), I finally got the bzz-bzz-bzz-bzz noise when I turned the craft on (Following your nice guide on the DJI forums, thank you for that).

Unfortunatly about 30 minutes into it, the buzzing stopped and the gimbal went limp. I left it running for roughly an hour before turning it off. Shortly before this happened the craft made the "booting up" noise a couple of times, not sure if that's abnormal though as some of the videos I watched said that it could do random things.

The log file showed that it was updating, then on the last section it had about 8-10 lines about a device being detected. (I stupidly deleted the file thinking I had backed it up. All I can say is that it WASN'T next to 0800 & 1500 as you indicate in your log file thread).

Past that, the craft reports that it's on 1.11.01.50+. Haven't tried controlling it at all, having a break for the rest of the night.

Sadly the camera (X3), no longer moves or shows footage. The fan still spins so there's that, but even in my Osmo it's limp. It's brand new so I assume the firmware bricked it somehow. The Osmo camera shows a feed on the craft so I think it's all good that side.

Any ideas please shoot them my way. I'll keep digging around for more info

Edit: Couldn't resist. Can confirm that the craft and RC are both fully updated and it has flight capability. That just leaves the servo (can fix), and the camera (ugh, please be able to fix. Got a good deal on it and the rest aren't cheap).
Glad you found the forum useful. There's a ton of information in it. That said...

You should now list your rollback procedure in detail so we can see where you went wrong. I assume you watched my tutorial videos. If not, search YouTube for "Make your Inspire 1 great again." It's a 2-part tutorial.

D
 

New Threads

Members online

Forum statistics

Threads
21,977
Messages
209,068
Members
32,289
Latest member
Shawnaoz