Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Received my Inspire back from RMA. Issue not resolved.

Joined
Sep 24, 2015
Messages
27
Reaction score
1
Age
35
Hi there. So I recently sent my Inspire into DJI's LA office, because it was constantly losing video signal and ultimately lost all signal while shooting over water, causing me to nearly lose the craft.

I received the unit back within two weeks, which surprised me, in a good way. What didn't make me so happy was the complete lack of documentation or communication regarding what they did to remedy the problem. Just my drone, in a box full of packing peanuts. I noticed they had replaced at least the camera's connection plate, as the three locking tabs did not have the same wear marks as before. They also put a handy (sarcasm) sticker in the camera box telling me how to correctly store the camera.

I took it out for a test flight and what do you know? Still losing video connection, albeit a bit less often, and for shorter durations. It also seems to happen more often when the craft is withi 30 or so meters of the RC.I didn't have an SD card in the craft for this flight as I just wanted to put it through it's paces.

This morning I drove to a beautiful mountaintop for sunrise and turned the Inspire on with SD card. It just started making constant loud beeps, about 1 second apart, and the LED was blank. Great. These were not the sounds I had ever heard from the firmware upgrades I had done before, I was perplexed and angry. I couldn't even get the craft out of flight mode to hike it back to my car....

Now I am at home and checked the log on the SD card and see that there was a new firmware released while it was in repair ( v.1.6.0.40). I had the previous firmware on the SD card. I feel they could have let me know they upgraded it at least. I'ts now (seemingly) happily updating after beeping LOUDLY for about 20 minutes with no LED.

So where should I go from here? I still have the connection issue. I will be traveling in April and need it in good working order. What are the chances of demanding a new unit? If they can't fix it at their repair center, something is obviously deeply flawed on the unit.

What do you guys recommend?

Thnaks
 
Joined
Nov 29, 2015
Messages
489
Reaction score
119
Hi there. So I recently sent my Inspire into DJI's LA office, because it was constantly losing video signal and ultimately lost all signal while shooting over water, causing me to nearly lose the craft.

I received the unit back within two weeks, which surprised me, in a good way. What didn't make me so happy was the complete lack of documentation or communication regarding what they did to remedy the problem. Just my drone, in a box full of packing peanuts. I noticed they had replaced at least the camera's connection plate, as the three locking tabs did not have the same wear marks as before. They also put a handy (sarcasm) sticker in the camera box telling me how to correctly store the camera.

I took it out for a test flight and what do you know? Still losing video connection, albeit a bit less often, and for shorter durations. It also seems to happen more often when the craft is withi 30 or so meters of the RC.I didn't have an SD card in the craft for this flight as I just wanted to put it through it's paces.

This morning I drove to a beautiful mountaintop for sunrise and turned the Inspire on with SD card. It just started making constant loud beeps, about 1 second apart, and the LED was blank. Great. These were not the sounds I had ever heard from the firmware upgrades I had done before, I was perplexed and angry. I couldn't even get the craft out of flight mode to hike it back to my car....

Now I am at home and checked the log on the SD card and see that there was a new firmware released while it was in repair ( v.1.6.0.40). I had the previous firmware on the SD card. I feel they could have let me know they upgraded it at least. I'ts now (seemingly) happily updating after beeping LOUDLY for about 20 minutes with no LED.

So where should I go from here? I still have the connection issue. I will be traveling in April and need it in good working order. What are the chances of demanding a new unit? If they can't fix it at their repair center, something is obviously deeply flawed on the unit.

What do you guys recommend?

Thnaks
I was having connection errors also. Turned out to be the cable I was using. Have you tried a different one?
 
Joined
Sep 24, 2015
Messages
27
Reaction score
1
Age
35
OK, never even thought of that. I'm gonna feel pretty stupid if that was the problem all along. Will update!
 
Joined
Jul 15, 2015
Messages
347
Reaction score
95
Location
Prince Edward Island, Canada
I received the unit back within two weeks, which surprised me, in a good way. What didn't make me so happy was the complete lack of documentation or communication regarding what they did to remedy the problem. Just my drone, in a box full of packing peanuts. I noticed they had replaced at least the camera's connection plate, as the three locking tabs did not have the same wear marks as before. They also put a handy (sarcasm) sticker in the camera box telling me how to correctly store the camera.
Jesse, l had a similar experience. I had a video issue that DJI diagnosed over the phone as a bad sensor. I packed it up in the original box, with the bubble wrap and cardboard packing that it came in. It was returned to me in a similar state as yours. It came in a flimsier box, also full of styrofoam peanuts and no documentation telling me what was done. Oh, also the RC which I included, with a loose antenna, was not returned. They have sent a new replacement RC but the only way I found out what they did to solve the video issue
was, when I checked the serial number of the camera it didn't match the original one I had. I guess they replaced the camera. Strange way of doing things.
 
Joined
Sep 24, 2015
Messages
27
Reaction score
1
Age
35
Alastair. Interesting.... I think they may have actually replaced the camera entirely as well. Hold, on.... Just checked the case and it has camera serial #, and it does not match the camera that came back. Well... Free camera replacement? OK. After I test with new USB cable, if it works I'll be happy? Still a bit perplexed at DJI though
 
Joined
Sep 24, 2015
Messages
27
Reaction score
1
Age
35
I hope it is the problem. easy fixed then. I noticed mine was playing up because I was charging my iPhone with it and it kept cutting out leaving me with uncharged batteries.
So here's what happened. I used a trusty USB cable that never gives out charging 18650 batteries daily. I set up the Inspire, and turned it on. The camera went through it's dance, and I had an image. Then when the calibration dance stopped, image AND RC signal were gone. Arrgh!!! I tried again, and same.

I then jiggled the gimbal plate and gave it a firm press into the body of the Inspire. It worked.... I flew through 2 TB48s with no connection issues. I agressively did side to side motions, which used to trigger the disconnection sometimes, steady as a rock. This leads me to believe the problem is indeed with the connection between the craft and the camera. As Alastair brought to my attention, I was given a new camera from the RMA, and this camera is giving me small twitches in video, which were not apparent before.

The problems never stop!
 
Joined
Oct 20, 2015
Messages
180
Reaction score
32
Age
73
Hi there. So I recently sent my Inspire into DJI's LA office, because it was constantly losing video signal and ultimately lost all signal while shooting over water, causing me to nearly lose the craft.

I received the unit back within two weeks, which surprised me, in a good way. What didn't make me so happy was the complete lack of documentation or communication regarding what they did to remedy the problem. Just my drone, in a box full of packing peanuts. I noticed they had replaced at least the camera's connection plate, as the three locking tabs did not have the same wear marks as before. They also put a handy (sarcasm) sticker in the camera box telling me how to correctly store the camera.

I took it out for a test flight and what do you know? Still losing video connection, albeit a bit less often, and for shorter durations. It also seems to happen more often when the craft is withi 30 or so meters of the RC.I didn't have an SD card in the craft for this flight as I just wanted to put it through it's paces.

This morning I drove to a beautiful mountaintop for sunrise and turned the Inspire on with SD card. It just started making constant loud beeps, about 1 second apart, and the LED was blank. Great. These were not the sounds I had ever heard from the firmware upgrades I had done before, I was perplexed and angry. I couldn't even get the craft out of flight mode to hike it back to my car....

Now I am at home and checked the log on the SD card and see that there was a new firmware released while it was in repair ( v.1.6.0.40). I had the previous firmware on the SD card. I feel they could have let me know they upgraded it at least. I'ts now (seemingly) happily updating after beeping LOUDLY for about 20 minutes with no LED.

So where should I go from here? I still have the connection issue. I will be traveling in April and need it in good working order. What are the chances of demanding a new unit? If they can't fix it at their repair center, something is obviously deeply flawed on the unit.

What do you guys recommend?

Thnaks
Drones Etc in Salt Lake go there
 
Joined
Sep 24, 2015
Messages
27
Reaction score
1
Age
35
So I went out to shoot the great surf today, thinking the issue had been mostly cleared up. NOPE. It's worse than before. I had to stop and restart the craft/RC over 2 dozen times because it would not connect, to get 4 flights, all of which ended because I lost the video connection. This thing is FUBAR. I am going to demand a new unit.
 
Joined
Nov 29, 2015
Messages
489
Reaction score
119
So I went out to shoot the great surf today, thinking the issue had been mostly cleared up. NOPE. It's worse than before. I had to stop and restart the craft/RC over 2 dozen times because it would not connect, to get 4 flights, all of which ended because I lost the video connection. This thing is FUBAR. I am going to demand a new unit.
Sorry to hear. I hope a quick recovery for you.
 
Joined
Sep 24, 2015
Messages
27
Reaction score
1
Age
35
Thanks. Now at home doing what I can diagnostically. Guess what? It connects just fine inside my home. Whereas an hour ago it wouldn't connect at all. This is driving me up the wall.
 
Joined
Sep 24, 2015
Messages
27
Reaction score
1
Age
35
Have you checked the connections of the two ribbon cables that attach to the gimbal socket above the vibration absorbing board?
Yes, multiple times. The first time the issue happened, I pushed them down with a chopstick (only thing at hand that would reach in there) and it seemed to make it better, but lately it hasn't made a difference.
 
Joined
Sep 24, 2015
Messages
27
Reaction score
1
Age
35
Hello everyone. So I received my Inspire back from it's 2nd RMA, again with zero communication from DJI, even though I emailed them multiple times at [email protected] which is supposed to be the direct line to the techs.

Well, it arrived back with some flimsy paper padding, and my case, which had a sticky zipper when it left, now has a completely unusable and ripped zipper! F*%k You DJI. Seriously. I have been patient and polite, and this is the service I receive. WOw.

So I powered it on. And behold - DISCONNECTED error AGAIN! I almost lost it.

I decided for some reason to unplug the micro USB from my Samsung tab and put it back in. The video feed came back to life. I took off, it disconnected again. MicroUSB out and in again, have video. So it appears I may have either a faulty tablet or a faulty controller (of which I have heard of many) Either way, this does not excuse the complete lack of communication by DJI, and the damaged case they returned. Now I have to spend hundreds of dollars on a replacement case.
 
Joined
Jan 4, 2016
Messages
16
Reaction score
1
Age
51
Location
Northern Wyoming
Man Jesse hate hearing this. It's such a shame that there are so many reports of unhappy RMA's with a company that is definitely making some cash. Do you know anyone with an iPad mini or another tablet you can test?

There are lots of original Inspire cases on eBay for pretty cheap but yes the principle is you shouldn't have to buy one when they messed up their cheap case!

If you want a nice backpack and have the X3 (either V1 or V2) I'd suggest the Inspak by Bestem Aerial. It is a so,I'd backpack and you can mod it for the V2 with the X5 gimbal mount. Hope you get your issue sorted and are flying again soon.
 

Attachments

New Threads

Members online

Forum statistics

Threads
19,384
Messages
190,149
Members
28,744
Latest member
Beanyboy