Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Tried to update firmware - lost connection?

Joined
Mar 6, 2015
Messages
111
Reaction score
30
Age
30
Hi.

So got my Inspire 1 yesterday, and tried to update the firmware today.
I put the SD card in the camera, launched the app and powered on the I1. I pressed "Update" or similar when the popupmessage asked me to update firmware. Few seconds later it lost the connection to the I1. everything just says "N/A". But it's making the beeping sound as described on the youtube video.

It's been 20mins now, and still doing the same. The radio sometimes makes beeping alarm because of inactive, but other than that nothing else happens.. should i just wait or will i risk bricking the device if i reboot it to try again?


Edit: So i tried to shut down the aircraft and boot up again. Still no connection. So tried to re-link the radio to the aircraft, but it won't link up with the I1. Any ideas?

Edit2: still won't link. The I1 just blinks yellow rapidly
 
Last edited:
Joined
Mar 6, 2015
Messages
111
Reaction score
30
Age
30
Oh well, the problem was that my radio required the update as well to be able to link. Short moment of panic here.

Resolved! :)
 
Joined
Nov 23, 2013
Messages
221
Reaction score
46
I'm having a problem linking a remote to the Inspire. Both remote and Inspire are updated to latest firmware. This has been verified by DJI with the hidden log file. The remote is also set to Master and should link. DJI's answer is for me to video the process and send it to them. That's just telling me that they don't trust my procedure - which is correct.

Does anyone have any ideas?
 
Joined
Mar 6, 2015
Messages
111
Reaction score
30
Age
30
You did press the button on the Inspire 1 to start the linking process?
 

New Threads

Members online

Forum statistics

Threads
19,393
Messages
190,243
Members
28,758
Latest member
RobYale