Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

USB Cord Fix Works For Me Dynamic RTH & Pilot App Crashes

Apr 30, 2015
Reaction score
I posted this as a reply on another thread. Hope this helps someone. It was Driving me NUTZ for over a Week. NO Sleep until Fixed. Whew............

I also had the RC Weak Signal Problem with
Dynamic RTH. and the App would Crash all the time. Spent a Week of sleepless nights trying everything I could think of.
I found that switching the Crappy Supplied USB cord Solved my Problem for the most part.

I was on hold twice with DJI's Customer Service trying to solve the problem. They said to send back the RC for repair. 5 to 6 week turn around. (WTF?) REALLY? But its only 3 days old and there goes half the Summer.

I then took it to my dealer. After an hour of troubleshooting the tech plugged it in to his I-phone.

The Blue GPS Dot showed up and the Dynamic RTH could be set for the first time.
YEEE HAAAAA! .....but not out of the woods yet.

He said it was my Note 4 and Lollipop O.S. Said they are having tons of issues with Lollipop.

I almost Factory Reset my Note 4 and was gonna install Kit Kat back on it. I have 3 android phones and a new Android Tab coming in the mail. Apple is out of the Question. Too much $$ on Android in the house.

Then I remembered to check the USB.

I noticed he did a double take on the LOOSE Supplied USB Cable. The wide end that plugs into the RC fit really Sloppy. Even tried the 2nd cable that DJI Supplied. Same Issues

I had a bunch of left over brand new USB cables from my Note 3. But they have the wider 3.0 USB.

Time to break out the Dremmel and carefully cut off the 3.0 connection. Did that in the past for some wireless chargers that would only fit a 2.0 cable.

Plugged it in and Bam A Blue Dot showed up. And I could set the Dynamic RTH With my Note 4 and Lollipop still installed. FINALLY.
On occasion when I walked around the dot would bounce back from blue to red but at least It works.

Nice going DJI if I would have listen to them I would be sitting here waiting for my RC to be returned only to probably still have the same problem.

I wonder how many others are having various problems due to the Crappy Cords?
It also seems to work even better with my USB and the older versions of the DJI Pilot App.

I'm not saying go out and get a USB 3.0 and cut the end off. Just stating to make sure you have a Good Quality Tight fitting one.

Hope they update soon with some Solid Software.
If you ask for help on here trying different USB cables is pretty much the first troubleshooting step you'll receive.
If you ask for help on here trying different USB cables is pretty much the first troubleshooting step you'll receive.
Yeah I should have known better and tried swapping to a different BRAND USB cord in the first place. I did try the 2nd Supplied DJI cord. Its a shame that for $ 3,000.00 DJI would put such cheap cords in the package.
Thanks KZ

New Posts

Members online

No members online now.

Forum statistics

Latest member