Welcome Inspire Pilots!
Jump in and join our free DJI Inspire community today!
Sign up

I2 noise (Issue identified)

Joined
Apr 25, 2017
Messages
60
Likes
26
#1
My two-week old I2 started making a high pitched pinging, beeping-like sound (it was not actually beeping) while hovering or making gentle maneuvers. Other than the noise, it has been stable and responsive and no issues at all (~3 hours and 10 flights). This noise started occurring on my 3rd flight. Video attached.

The props are brand new, no damages, they were seated snugly without any play. When turning the props by hand, they were all smooth, no strange or clicking noise. After the flight the motors were all about the same temperature.

Anything else I can check? Is this something to be worried about?

Thanks for your input.

Alex

 
Joined
Jan 29, 2017
Messages
98
Likes
26
Age
40
#2
Seems like it could be the gimbal making those sounds as it only occurs when you are yawing the aircraft.
 
Joined
Jan 12, 2015
Messages
1,520
Likes
393
Location
Worldwide
#3
My two-week old I2 started making a high pitched pinging, beeping-like sound (it was not actually beeping) while hovering or making gentle maneuvers. Other than the noise, it has been stable and responsive and no issues at all (~3 hours and 10 flights). This noise started occurring on my 3rd flight. Video attached.

The props are brand new, no damages, they were seated snugly without any play. When turning the props by hand, they were all smooth, no strange or clicking noise. After the flight the motors were all about the same temperature.

Anything else I can check? Is this something to be worried about?

Thanks for your input.

Alex

Your not alone. I get to same sound.
 
Joined
Jan 29, 2017
Messages
98
Likes
26
Age
40
#4
Have you tried powering on the I2 and then picking it up and turning it so the gimbal has to engage to see if the noise is present?
 
Joined
Apr 25, 2017
Messages
60
Likes
26
#5
I tried the following:

1) Hand hold the I2 and rotate. Gimbal makes noise when yawing.

2) Remove X5S from I2 and perform same hovering and yawing as in my previous video, the noise disappears.

So at this point I'm pretty sure it is the gimbal. An RMA has been filed with the vendor.

Thanks for your input @r62ewa. You are spot on.
 
Joined
Jan 12, 2015
Messages
1,520
Likes
393
Location
Worldwide
#6
I tried the following:

1) Hand hold the I2 and rotate. Gimbal makes noise when yawing.

2) Remove X5S from I2 and perform same hovering and yawing as in my previous video, the noise disappears.

So at this point I'm pretty sure it is the gimbal. An RMA has been filed with the vendor.

Thanks for your input @r62ewa. You are spot on.
Any updates, I have the same issue, debating on sending in for repair.
 
Joined
Apr 25, 2017
Messages
60
Likes
26
#9
After exchanging for a new X5S, the noise persisted. Subsequent flying the I2 by itself (without X5S) resulted the same sound being present (I don’t know why the noise wasn’t there the first time I flew it without the gimbal). I ended up exchanging for a new I2 before my 30 day was up. Now all is well. No more noise.

Throughout this, I’d like to thank @Advexure for their prompt replies to my email inquiries even though I did not purchase the items from them. I will be sure to use them for future services.
 
Joined
Jan 12, 2015
Messages
1,520
Likes
393
Location
Worldwide
#10
After exchanging for a new X5S, the noise persisted. Subsequent flying the I2 by itself (without X5S) resulted the same sound being present (I don’t know why the noise wasn’t there the first time I flew it without the gimbal). I ended up exchanging for a new I2 before my 30 day was up. Now all is well. No more noise.

Throughout this, I’d like to thank @Advexure for their prompt replies to my email inquiries even though I did not purchase the items from them. I will be sure to use them for future services.
10;4
 

Advexure

Approved Vendor
Joined
May 1, 2015
Messages
1,442
Likes
621
Location
Los Angeles, CA
Website
www.advexure.com
#11
After exchanging for a new X5S, the noise persisted. Subsequent flying the I2 by itself (without X5S) resulted the same sound being present (I don’t know why the noise wasn’t there the first time I flew it without the gimbal). I ended up exchanging for a new I2 before my 30 day was up. Now all is well. No more noise.

Throughout this, I’d like to thank @Advexure for their prompt replies to my email inquiries even though I did not purchase the items from them. I will be sure to use them for future services.
Glad our team could assist along the way and that you are back airborne with no more noise. Safe flying!
 

New Threads

Forum statistics

Threads
17,761
Messages
178,681
Members
26,231
Latest member
Pedestal