Welcome to InspirePilots.com

Join the leading DJI Inspire community for free!

Phantom 3 Advanced Firmware Problem 03/07/16 AHHH!

Discussion in 'General Discussion' started by Chris Bell, Mar 7, 2016.

  1. Help me with my drone firmware phantom 3

    1 vote(s)
  2. This should be easy but can't figure this out phantom 3 advanced

    1 vote(s)
Multiple votes are allowed.
  1. Chris Bell

    Mar 7, 2016
    Likes Received:
    This issue is driving me MAD!!!

    I had a Standard Phantom 3 installed firmware with no problem. Sold it to get a Phantom Advanced because i wanted the 3 mile range.
    Unboxed and downloaded a new version of the DJI app on my iPhone 6 plus. Charged the battery to 100%
    Inserted battery in drone and turned on. Powered on remote opened app and camera connected.

    This is what pops up.
    So i clicked on firmware requires upgrade and this message pulled up without any install buttons.
    I'm unable to upgrade/install my firmware
    I tried to reset the drone and controller and checked all connections from controller to iPhone 6
    I formatted the sd card and restarted and still displayed this message.

    I've tried to download the dji software using the bin file to the SD card on my mac computer and couldn't get the file to transfer.

    Does anyone have any other solution to downloading the New Firmware.

    Thanks for your time in helping me!

    Atlanta GA
  2. Skynet1

    Apr 20, 2014
    Likes Received:
    You may already have the latest firmware, check it in the ABOUT section of the Go App. If you are already on the latest version of firmware then try simply powering up the model with each of the batteries you have, go fly to 50% of battery remaining then recharge and see if the message remains or disappears. Personally, I wouldn't fuss with the software, as this may only create a bigger issue for you. Naturally you do what you feel best. Best of luck with your new Phantom.
  3. The Editor

    The Editor Moderator
    Staff Member

    Aug 7, 2013
    Likes Received:
    Hello, and welcome to the forum - you may have better luck over on the PhantomPilots forum since this one is dedicated to the Inspire. :)
    Try: DJI Phantom Forum