Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Slave RC issues

Aug 6, 2016
Reaction score
I have a slave controller that I tried to update the firmware on. The update failed and now On power up, the led turns red, beeps twice, then turns purple and does nothing. Can anyone help me please?
After reading Simon's suggestion to delete the DJI GO app,
I solved this issue this morning in 15 minutes.

My Master was already upgraded with my Samsung Galaxy Tab S2.
I use my Samsung Galaxy S5 cell on my slave . I uninstalled my DJI Go app on my S5, waited 2 minutes then re-installed the GO APP via the Google app store.

I then turn on the Slave Transmitter only ans the the S5.
The update required message was there. I did the update which took about 4 minutes. Shut off the Slave and S5. Re-started both and got the red led with the error and beeping. I shut bothe down again. Restarted wih out the error. Shur down both again.

I then turned the Master on then the Tablet then the Inspire. After confirming Master and Inspire operating normally I turned on the Slave and the S5. I had a picture on the S5 but no control of camera. I had to reset the Slave as "Slave".

Remembering that the Controllers return to default I reset my Slave under the "Custom" settings that I prefer for my Slave. I then did the search for Master and put in the master name and pass code.

The final thing if I recall correctly was to request control from the Master from the Slave.

It appears everything is working as normal but I have not taken a flight yet.

I will tomorrow. 8/8

Thank you Simon

Members online

Forum statistics

Latest member