Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

X5S servo noise and constant rattle after firmware update

Joined
Feb 20, 2017
Messages
448
Reaction score
116
Age
41
A few of us have been discussing this in another thread, but after a few firmware refreshes, and calibration of everything, the issue still exists.

My issue is the noise at startup after a quiet initialization accompanied by felt vibration and visible shaking of the gimbal. Followed by a constant lower vibration of the uppermost servo, also accompanied by noise.

Other users have reported camera not aligning straight as well.

As an engineer, I'd say leave the camera off until this is sorted, as this may burn out the servo if what I'm hearing is what I think they answer doing electrically.


Of course, DJI says calibrate IMU... idiots.
 
A few of us have been discussing this in another thread, but after a few firmware refreshes, and calibration of everything, the issue still exists.

My issue is the noise at startup after a quiet initialization accompanied by felt vibration and visible shaking of the gimbal. Followed by a constant lower vibration of the uppermost servo, also accompanied by noise.

Other users have reported camera not aligning straight as well.

As an engineer, I'd say leave the camera off until this is sorted, as this may burn out the servo if what I'm hearing is what I think they answer doing electrically.


Of course, DJI says calibrate IMU... idiots.
Yes - calibrate the IMU and it will make your batteries last longer in flight, you will get faster climb outs and much longer range - well thats the DJI answer to everthing :rolleyes:

Is your camera perfectly balanced? i.e. with the gimbal powered down you can pretty much manually put the camera in any position and it will stay there?
 
  • Like
Reactions: EDDSkitz
I'm not the only one with the issue, zero issue yesterday before the firmware. This is 10000000% a DJI screw up, yet again.
 
I'm not the only one with the issue, zero issue yesterday before the firmware. This is 10000000% a DJI screw up, yet again.
Oh I'm not doubting it - DJI's 'Flag Ship's product suffers the same issues as their entire product line - crap firmware writing.

At the end of the day this will be totally down to poor PID tuning on the GCU - I guarantee it.
You would think they could actually get that right by now. :rolleyes:
 
  • Like
Reactions: EDDSkitz
Oh I'm not doubting it - DJI's 'Flag Ship's product suffers the same issues as their entire product line - crap firmware writing.

At the end of the day this will be totally down to poor PID tuning on the GCU - I guarantee it.
You would think they could actually get that right by now. :rolleyes:
I was literally just told it's a **NORMAL** PID operation... [emoji23] [emoji23] [emoji23] [emoji23] [emoji23]

This company is a joke.
 
09916a76e73ada9d567f39a4db97799b.jpg
 
My X5S after updating, makes a noise according to I turn the device the camera is focused and it makes a terrible for 5 seconds, after all the performance
 
Not only makes noise when centering the camera, a loud noise, then the normal Yaw noise of the servo up and down light,
 
Yup, exactly... DJI is trying to say that's normal now... both on the phone and one of their testers.
 
OK, this issue has now been reported to DJI and will be forwarded to R&D.

I have spoken to Ken (Blade Strike) and he is escalating the problem.
 
  • Like
Reactions: EDDSkitz
Everyone has the same problem and for DJI everything is normal, I do not see it as normal, I notice how the engine is forced for 5 seconds, I do not understand these problems with the DJI experience
 
  • Like
Reactions: EDDSkitz
Everyone has the same problem and for DJI everything is normal, I do not see it as normal, I notice how the engine is forced for 5 seconds, I do not understand these problems with the DJI experience
Apparently it's considered attacking if you point out there's an issue.
 
I've been speaking with DJI support for an hour, they're all normal at the moment, I just want my X5S not to suffer
 
  • Like
Reactions: EDDSkitz
I've been speaking with DJI support for an hour, they're all normal at the moment, I just want my X5S not to suffer
I spent three hours total with them this morning just the have them tell me this is all normal now.
 
Then I spent the afternoon being attacked for pointing it out until I sent a nice email over to corporate, now it seems like they are willing to admit possibly there's an issue.

Unfortunately it's gonna need a new update to fix it, as nothing we can do will fix it.
 

New Posts

Members online

No members online now.

Forum statistics

Threads
22,313
Messages
210,825
Members
34,660
Latest member
MichaelaOrita