Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Buzzing, landing gear, camera no pic

Joined
Jun 8, 2015
Messages
14
Reaction score
1
Age
49
I
Hey everybody. I have an emergency. I am on a shoot with several issues.
1. No video image from camera is being displayed on iPads.
2. LOUD buzzing noise in cone.
3. Landing gear will not lower or raise. Landing gear is stuck in Landing mode and will not raise for flight. Also, I can tell I1 to go to travel mode and blue tail light will be active, but landing gear will not be lowered for travel mode.







Any ideas how to solve issues while on production location?
 

Attachments

Last edited:
Joined
Dec 28, 2015
Messages
251
Reaction score
87
Age
37
Location
Madawaska Maine, USA
Sounds like an issue with the worm gear. Can you manually try to turn it? It might just be stuck in place and can be freed with a bit of a twist.
 
Joined
Apr 30, 2017
Messages
540
Reaction score
156
Age
43
Is the FC the Ncore component? The fan on it spins freely and the I1 can take off for flight with movements, but the arms do not lower or raise.

DJI Inspire 1 Ncore component
Yes that would be it. Has several names from being called lightbridge, N core, flight controller and a few other. Pull the plastics off .Take the 3 screws out of the black wire cover on the right hand side and remove it and unplug the servo motor for the landing gear. It’ll be the black plug with the gray,brown,and black wires and see if it stops buzzing. If it doesn’t problem is either the power board or the fc. Does it do it with any battery you use or is it happening with just one or two batteries?
 

New Threads

Members online

Forum statistics

Threads
20,336
Messages
197,306
Members
29,883
Latest member
Country55