Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

inspire one has no camera signal and wont update.

Joined
Aug 12, 2014
Messages
319
Reaction score
45
Location
GUerneville Ca.
my inspire1 has set in a cold room for a couple of months and I took it to the ocean the other day and left it sitting for a few hours where it did get some salt spray on it. the camera was not attached and i wiped it off and attached the camera. not sure if salt salt water got inside,but now i get no camera signal and i can not do a craft firmware update.the camera does not move upon start up so it seems there is no power to it. the motors start and all else seems fine. Camera and battery has been taken out a few times and I left it inside where it was warm and dry for a few days with still nothing. i took off the plate and reinserted the two connectors underneath with still no luck.
any ideas before I try to take it very much apart?
thanks all.
 
Last edited:
Joined
Apr 3, 2017
Messages
4
Reaction score
0
Age
39
Sounds like you are having the same problem as me, the craft wouldn't raise the legs on takeoff and now it won't go into travel mode. This was yesterday and Since then I have tried again but now the gimbal won't initialise on start up. The craft connects to the controller and I have relinked and that was successful but starting to wonder if the possible £700 repair bill will be my only option :(
 

New Threads

Forum statistics

Threads
19,401
Messages
190,301
Members
28,768
Latest member
Keith T