Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

No rollback versions showing up on Controller

Joined
Jun 20, 2015
Messages
4
Reaction score
0
Age
70
App on tablet is 3.1.52
Version on Inspire 1.11.01.50
Camera 1.10.01.40
Remote 1.7.80

I have an original Inspire 1 that I'm going to redo with v 1.8.1.00. I just tried (on android tablet) to roll back from 1.7.80 on my remote controller hoping to go back to 1.6.0. When the Rollback menu comes up it says there is no firmware to roll back to .

I'm comfortable rolling back the Inspire Firmware, but lost on how to overcome my controller rollback. Through the years I've used different phones and different tablets. Is there a chance there might be some firmware to rollback to on an old device?

Any ideas?

Also how might I get an older version of DJI GO that plays nice with 1.181.

TIA
 
Joined
Apr 22, 2016
Messages
398
Reaction score
114
Location
Sofia
Website
goldenskybirds.com
App on tablet is 3.1.52
Version on Inspire 1.11.01.50
Camera 1.10.01.40
Remote 1.7.80

I have an original Inspire 1 that I'm going to redo with v 1.8.1.00. I just tried (on android tablet) to roll back from 1.7.80 on my remote controller hoping to go back to 1.6.0. When the Rollback menu comes up it says there is no firmware to roll back to .

I'm comfortable rolling back the Inspire Firmware, but lost on how to overcome my controller rollback. Through the years I've used different phones and different tablets. Is there a chance there might be some firmware to rollback to on an old device?

Any ideas?

Also how might I get an older version of DJI GO that plays nice with 1.181.

TIA
I'm with the latest firmware and just tried on my Samsung N4 with DJI GO 3.1.23 and there is rollback available, so maybe you should go for older GO version to do it.
 
Joined
May 22, 2019
Messages
14
Reaction score
5
Age
57
Once you update to fw1.11 theres no going back, dji stopped that
 
Joined
Mar 23, 2019
Messages
59
Reaction score
27
Age
47
Once you update to fw1.11 theres no going back, dji stopped that
I just rolled back from V1.11.01.50+ to V1.08 on aircraft and from V1.7.80 to V1.6.0 on the controller. However I'm on iOS and GoApp 3.1.64.
 
Joined
May 22, 2019
Messages
14
Reaction score
5
Age
57
I just rolled back from V1.11.01.50+ to V1.08 on aircraft and from V1.7.80 to V1.6.0 on the controller. However I'm on iOS and GoApp 3.1.64.
Did you use the FW and info i sent you? As you cant do this once on FW1.11 via the app
 
Joined
Apr 23, 2020
Messages
73
Reaction score
28
Location
Salt Lake City, UT
App on tablet is 3.1.52
Version on Inspire 1.11.01.50
Camera 1.10.01.40
Remote 1.7.80

I have an original Inspire 1 that I'm going to redo with v 1.8.1.00. I just tried (on android tablet) to roll back from 1.7.80 on my remote controller hoping to go back to 1.6.0. When the Rollback menu comes up it says there is no firmware to roll back to .

I'm comfortable rolling back the Inspire Firmware, but lost on how to overcome my controller rollback. Through the years I've used different phones and different tablets. Is there a chance there might be some firmware to rollback to on an old device?

Any ideas?

Also how might I get an older version of DJI GO that plays nice with 1.181.

TIA
I recently did this and I thought the same thing at first but you gotta scroll down on that menu to see the past RC firmware versions. It’s not obvious
 

New Threads

Members online

Forum statistics

Threads
20,675
Messages
199,888
Members
30,264
Latest member
nearchos