Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Pilot App hangs Samsung Galaxy Tab S after Lollipop upgrade

Joined
May 8, 2015
Messages
25
Reaction score
2
Age
61
Location
Nashua, New Hampshire
Using the Samsung Galaxy Tab S (8.4) with Android Kit Kat (4.4.2) and Pilot App (1.0.10) worked great for me and had experienced no problems.

Once the Tab S upgraded to Lollipop (5.0.2), the Pilot App began to slow down and hang mid-flight. It didn't effect the flying of the Inspire but all the app's touch-screen and hard button functionality like the recording button, camera control and other controls began lagging and eventually stopped responding.

I stopped the app's task, because even trying to exit the app normally was not possible since it was hung up. I then restarted the app and worked OK for a little while and then the same thing began to happen after a few minutes.

I tried uninstalling and reinstalling the Pilot App (1.0.10) and still the same situation.

I did a master reset on the Tab S and installed the latest Pilot App (1.1.0) from the DJI website. It still exhibits the same issue.

Is anyone else experiencing this with the Tab S or any other Android device since the new Android Lollipop upgrade?

Thanks!
 
Joined
May 6, 2015
Messages
30
Reaction score
15
Age
42
Same issue with kit kat 4.4.2 here , but i started experiencing serious lag with the last fw update.
 
Joined
May 8, 2015
Messages
25
Reaction score
2
Age
61
Location
Nashua, New Hampshire
Hmmm... so it could be the firmware update causing this and not the Lollipop update!? The update to Lollipop happened first and then the firmware happened within a week, and I didn't fly in between time. I pointed my finger at Lollipop when if fact it could be the firmware.

I wonder if it's possible to roll-back to the previous firmware version (v1.2.1.03) which I still have on my computer?
 
Joined
May 8, 2015
Messages
25
Reaction score
2
Age
61
Location
Nashua, New Hampshire
Thanks for the link Prax...

I wish I didn't update all my batteries so I could determine if the firmware caused this or Lollipop. Or, flew after the Lollipop update and before the firmware update.
 
Joined
May 22, 2013
Messages
160
Reaction score
18
I just purchased my I1 last Friday. I also purchased the Samsung S 8.4 because best buy claimed to be one of the fasted proccessers available. I am having the same issues about 12 to 15 min into the flight I start getting lots of lag of time. I will watch the temp tonight and see if that is the issue. hope we have a fix for it soon.
 
Joined
May 22, 2013
Messages
160
Reaction score
18
Thanks for the report brad90631!
Are you also running Lollipop or still Kit Kat?
I am running Lollipop. I made the mistake and upgraded my tablet as soon as I got it home.

even with the lag, I must say I have had 2 phantoms version 1 and a later version 1, and the inspire is like going from a pinto to a corvette.
 
Joined
May 8, 2015
Messages
25
Reaction score
2
Age
61
Location
Nashua, New Hampshire
I will watch the temp tonight and see if that is the issue. hope we have a fix for it soon.
I'll be curious what your temps will be. I won't have time to fly tonight but currently I have the Samsung connected to the remote controller with the Pilot App running and the (RC is on, AC is off) and I'm reading about 75 degrees C.
 
Last edited:
Joined
Oct 5, 2014
Messages
171
Reaction score
55
Location
Connecticut, USA
Same issues here. Everything on my tablet was working moderately OK until I did the lollipop upgrade. By moderately I mean I always had a significant lag with the Samsung even under kitkat. So everything was working as I said even after all the Inspire upgrades so it has nothing to do with the Inspire firmware upgrades and everything to do with the android upgrade. Problems encountered include major lag in the video; pilot app hanging mid flight; sometimes I couldn't even get past the menu screen of the app before it would hang. I am sure it has something to do with the pilot app not being compatible with lollipop, but this android version has been out for some time now, so why the incompatibility? Beside all of this, I am tired of the android not having the same features as the IOS version. Today the tablet goes to my grandsons. I ordered an IPad Mini2. I never buy apple crap, but it seems to be the only way my Inspire will take to the air!
 
Joined
May 6, 2015
Messages
30
Reaction score
15
Age
42
Oh wait... I am running Lollipop 5.0.2 actually, i didn't see the upgrade coming.
Lollipop could definitely be the faulty one then..
 
Joined
May 8, 2015
Messages
25
Reaction score
2
Age
61
Location
Nashua, New Hampshire
I ordered an IPad Mini2. I never buy apple crap, but it seems to be the only way my Inspire will take to the air!
Thanks for confirming this to be an issue with the Pilot app and Lollipop. And who knows when a fix will be released by DJI.

I'm using the Inspire for my business and it needs to be working reliably now! When the client calls, I've got to be ready to go. I too will look into the Mini 2. I've also never owned an Apple product, but if it's going to work...
 

The Editor

Moderator
Staff member
Joined
Aug 7, 2013
Messages
10,010
Reaction score
5,256
Running Lollipop 5.1 here and no issues. (Nvidia Shield)
 

The Editor

Moderator
Staff member
Joined
Aug 7, 2013
Messages
10,010
Reaction score
5,256
Ok thanks, I'll look into that also! Any particular model I should look for with the Nvidia Shield (not familiar)?
There is only one (although soon to be two). Its one of if not THE most powerful Android tablets out there and Nvidia are one of the quickest at getting OS updates out there to the end user.
 
Joined
Oct 5, 2014
Messages
171
Reaction score
55
Location
Connecticut, USA
Running Lollipop 5.1 here and no issues. (Nvidia Shield)
Maybe 5.1 is the answer. But its not available on the Samsung. The Samsung is a great tablet, but it sucks as a device for the Inspire. The latency is horrible even when the device is working. Sounds like Nvidia is a popular choice but my IPad arrives on Monday. Then I will have the flight simulator and other features the android app is missing.
 
Joined
Dec 6, 2013
Messages
6
Reaction score
1
Age
59
Location
San Luis, Argentina.
Website
www.proland.com.ar
Hi, I have Lollipop 5.0.1 in Samsung Tablet S, and experiment something problems with the break video signal (disconnectted), but is de "know" problem tipycal for the App Pilot for Android. But after all, functional OK for me.
 

New Threads

Members online

Forum statistics

Threads
19,739
Messages
192,973
Members
29,108
Latest member
Keith Christ