Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

RC Signal Weak or No RC Signal

Joined
Feb 17, 2015
Messages
4
Reaction score
0
Age
65
Tried to fly for the first time but got RC Signal Weak or No RC Signal. I was 4 feet away from the Inspire but distance telemetry said I was 27'. Rebooted and then distance said I was 500' away. I can get it to take off but it returns to home since it has lost it's signal. Temp is 9 degrees F but all batteries indicate full charge.
 
Joined
Apr 1, 2015
Messages
9
Reaction score
4
Age
53
I am having this same issue right away. Was able to update firmware and play in the house with flight simulator a few minutes and charged all my batteries and went out last Saturday for the first time at a RC field. Noticed a quick glitch as I was flying FPV and didn't see my iPad or controller to see what had happened. I just dismissed it. Then Monday night I took it out after work to show a friend and had "Weak RC Signal" display with frequent pops indicating "Aircraft Disconnected". I was within 10 feet of the aircraft and watching the green / red led on the controller show a almost oscillating connection. Re-powering the aircraft helps for a short but it always comes back. I have tried in multiple places far from any Wifi, Cellular or other interference. DJI upon both my calls simply says there is nothing they can do for troubleshooting steps and I should get a replacement. Tech Gadgets a Amazon seller promptly apologized for my trouble and sent me a Fed Ex ship label to return for replacement. Thankfully the RTH kept it in perfect condition for the exchange.

There is a post like this in the DJI forums but it dead ended with no stated conclusion by the originator. I'm curious what others have done to resolve this.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
19,756
Messages
193,079
Members
29,125
Latest member
Sr.DiogoSilva