Welcome Inspire Pilots!
Join our free DJI Inspire community today!
Sign up

Weird SD card (or X3?) malfunction

Joined
Dec 22, 2016
Messages
32
Reaction score
4
Age
33
I've been dealing with the weirdest problem during past week and half. I use two 64gb cards for my X3 -
a SanDisk Ultra and an ADATA Premier. Both had worked file recording 4K video for the 3-4 weeks I have had them.

That is until last week when first my X3 started sporadically stopping recordings, giving a 'SD card too slow, reformat recommended" error and lagging like crazy. When the problem first appeared, it was the ADATA that was being used, but the exact same issue appeared I switched to the SanDisk.

I tried every conceivable way to format the cards - using the DJI GO app, the SDFormatter mac app, formatting with Unix in fat32 & exfat with both table format settings, quick and low-level format.

Same thing every time - the camera starts normally, records for 3 or 4 minutes as expected, returns the "SD card formatting recommended" error, then starts lagging like crazy and dropping recordings after 10-15 seconds. It even lags severely when taking photos.

I did crash my I1 just a week or so before the first time the problem occurred, so at this point I was convinced my X3 or something downstream from it had gone kaput.

And then I decided to try out another card, just in case.

I got a 32gb ADATA (not sure what model it is, from the card itself, I can only make out its class 10), popped it in the X3 and all problems disappeared. No errors, no dropped recordings, no lagging, just like that.

I am now completely unsure of what to think. Any ideas?
 
Joined
Dec 22, 2016
Messages
32
Reaction score
4
Age
33
Short update, also posted on forum.dji.com:

Just did a downgrade & upgrade (down to V01.09.01.30 and back up to V01.10.01.40), testing with a 64gb card after each with no luck on resolving the issue.

The behaviour is always the same:
- The I1 initially launches and works normally
- I start recording a video (4K, 30fps) and leave it running
- At around 4:30min, the recording stops automatically
- From thereon, start/stop recording commands are really laggy and the camera automatically stops recording after about 10 seconds of starting a new recording
- The behaviour on my osmo is identical, except there I also get a "SD card is too slow, reformat recommended" popup which I just noticed doesn't show up when the X3 is mounted on the I1

My guess is that card writing speed is severely lowered by an unknown factor, so the X3 writes onto its buffer memory until it fills up and then automatically stops the recording. As already mentioned, the issue completely disappears as soon as I put in a 32gb card. Let me know if you have any thoughts or suggestions!
 
Joined
Nov 27, 2016
Messages
110
Reaction score
25
Age
39
Another reason why I am firmly staying with v1.9 firmware :) Did it work (did you test) ok when you went back to 1.9?
 
Joined
Dec 22, 2016
Messages
32
Reaction score
4
Age
33
Another reason why I am firmly staying with v1.9 firmware :) Did it work (did you test) ok when you went back to 1.9?
Unfortunately, the problem persists, so it doesn't seem to be related to FW version.
 
Joined
Jan 8, 2017
Messages
75
Reaction score
16
Age
67
My hunch is that it is related to using 64gb microSDXC cards and ExFAT format issues. I am sticking with 32gb microSDHC cards, and formatting in the Inspire, which I believe will use FAT32. I have to land every 20 minutes or so for a fresh battery anyway, so it is no problem to swap in a card.
 
  • Like
Reactions: Cornscot
Joined
Dec 22, 2016
Messages
32
Reaction score
4
Age
33
That might well be the case, although I don't why both cards worked without issue for a few weeks before they started acting up. I guess I''ll have to purchase a few 32gb cards until the issue is resolved..
 
Joined
May 27, 2016
Messages
231
Reaction score
97
Age
62
It sounds like your card can not handle the 60MB/s write speed needed for the Inspire 1. Many card manufactures only mention the read speed and not the write speed.

Which 64 GB card are you using?
 

New Threads

Forum statistics

Threads
19,393
Messages
190,216
Members
28,752
Latest member
Thecabinetman